<!DOCTYPE html>
<html lang="en-US" xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://idahobusinessreview.com/xmlrpc.php" />
<title>Larry H. Miller to Share the Love for the ninth year &#8211; Idaho Business Review</title>

<!-- All in One SEO Pack 2.3.10.2 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<link rel="canonical" href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Idaho Business Review &raquo; Feed" href="http://idahobusinessreview.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Idaho Business Review &raquo; Comments Feed" href="http://idahobusinessreview.com/comments/feed/" />
<meta name="apple-mobile-web-app-title" content="  Larry H. Miller to Share the Love for the ninth year">
<link rel="apple-touch-icon" sizes="57x57" href="http://idahobusinessreview.com/files/2014/03/1br57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="http://idahobusinessreview.com/files/2014/03/1br72.png" />
<link rel="apple-touch-icon" sizes="114x114" href="http://idahobusinessreview.com/files/2014/03/1br114.png" />
<link rel="apple-touch-icon" sizes="144x144" href="http://idahobusinessreview.com/files/2014/03/1br144.png" />

<!-- thumbnail action -->

<!-- post-id:183925: -->

<!-- thumb_id:: -->

<!-- url:: -->

<!-- WordPress Facebook Open Graph protocol plugin (WPFBOGP v2.0.13) http://rynoweb.com/wordpress-plugins/ -->
<meta property="fb:admins" content="1425649256"/>
<meta property="og:url" content="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/"/>
<meta property="og:title" content="Larry H. Miller to Share the Love for the ninth year"/>
<meta property="og:site_name" content="Idaho Business Review"/>
<meta property="og:description" content="Larry H. Miller Subaru Boise has selected Big Brothers Big Sisters of Southwest Idaho as their hometown charity to be added to the list of organizations that cu"/>
<meta property="og:type" content="article"/>
<meta property="og:image" content="http://idahobusinessreview.com/files/2016/02/stacked-facebook-profile.jpg"/>
<meta property="og:locale" content="en_us"/>
<!-- // end wpfbogp -->
<link rel="alternate" type="application/rss+xml" title="Idaho Business Review &raquo; Larry H. Miller to Share the Love for the ninth year Comments Feed" href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/idahobusinessreview.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-polls-css'  href='http://idahobusinessreview.com/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://idahobusinessreview.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='tie-style-css'  href='http://idahobusinessreview.com/wp-content/themes/jarida/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='Oswald-css'  href='http://fonts.googleapis.com/css?family=Oswald%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://idahobusinessreview.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://idahobusinessreview.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='dmcssStylesheet-css'  href='http://idahobusinessreview.com/wp-content/plugins/tdc-paywall/style.css' type='text/css' media='all' />
<script type='text/javascript' src='http://idahobusinessreview.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/tdc-paywall/login_form.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/google-analyticator/external-tracking.min.js'></script>
<link rel='https://api.w.org/' href='http://idahobusinessreview.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://idahobusinessreview.com/xmlrpc.php?rsd" />
<link rel='prev' title='Micron employees donate 912 turkeys and 324 hams' href='http://idahobusinessreview.com/2016/11/22/micron-employees-donate-912-turkeys-and-324-hams/' />
<link rel='next' title='Boys &#038; Girls Clubs of Ada County expands to Kuna' href='http://idahobusinessreview.com/2016/11/22/boys-girls-clubs-of-ada-county-expands-to-kuna/' />
<link rel='shortlink' href='http://wp.me/p2XDCg-LQx' />
<link rel="alternate" type="application/json+oembed" href="http://idahobusinessreview.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fidahobusinessreview.com%2F2016%2F11%2F22%2Flarry-h-miller-to-share-the-love-for-the-ninth-year%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://idahobusinessreview.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fidahobusinessreview.com%2F2016%2F11%2F22%2Flarry-h-miller-to-share-the-love-for-the-ninth-year%2F&#038;format=xml" />

<meta name='google-site-verification' content='pdIfxBOwt8N_Zpc5UZ3AIrXpeYa5v0h0Jnr8IiS1W-A' />
<meta name='y_key' content='877cbb0bd73c44cd' />
<meta name='msvalidate.01' content='118D5E2D5722A6F1A827250C4D8CEC95' />
<meta name="generator" content="WordPress" /><!-- START Quantcast By WP-Plugin: Quantcast-Quantifier http://wordpress.org/extend/plugins/quantcast-quantifier/ -->
<!-- Start Quantcast tag -->
<script type="text/javascript">
_qoptions={
qacct:"p-29W-admf9poxY", 
labels:"Business"
};
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
<noscript>
<img src="http://pixel.quantserve.com/pixel/p-29W-admf9poxY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>
<!-- End Quantcast tag -->

<script type="text/javascript">
    __compete_code = '0406a660fcef05313cf19e49a64a9f9b';
    (function () {
        var s = document.createElement('script'),
            e = document.getElementsByTagName('script')[0],
            t = document.location.protocol.toLowerCase() === 'https:' ?
                'https://c.compete.com/bootstrap/' :
                'http://c.compete.com/bootstrap/';
            s.src = t + __compete_code + '/bootstrap.js';
            s.type = 'text/javascript';
            s.async = true;
            if (e) { e.parentNode.insertBefore(s, e); }
        }());
</script>

<!-- END Quantcast-Quantifier --><style>.post-thumbnail img[src$='.svg'] { width: 100%; height: auto; }</style>
<meta name="author" content="IBR Staff" />
<link rel="shortcut icon" href="/files/2014/03/1br17.png" title="Favicon" /><!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="http://idahobusinessreview.com/wp-content/themes/jarida/js/html5.js"></script>
<script src="http://idahobusinessreview.com/wp-content/themes/jarida/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="http://idahobusinessreview.com/wp-content/themes/jarida/css/ie8.css" />
<![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<style type="text/css" media="screen">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</style>
<style type="text/css" media="all">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</style>
<!-- Start of Act On Beacon Code -->
<script>/*<![CDATA[*/(function(w,a,b,d,s){w[a]=w[a]||{};w[a][b]=w[a][b]||{q:[],track:function(r,e,t){this.q.push({r:r,e:e,t:t||+new Date});}};var e=d.createElement(s);var f=d.getElementsByTagName(s)[0];e.async=1;e.src='//news.idahobusinessreview.com/cdnr/50/acton/bn/tracker/22733';f.parentNode.insertBefore(e,f);})(window,'ActOn','Beacon',document,'script');ActOn.Beacon.track();/*]]>*/</script>
<!-- End of Act On Beacon Code -->
<!-- Google Analytics Tracking by Google Analyticator 6.5.0: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'disabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-10379233-4', 'auto');
 
	ga('send', 'pageview');
	_gaq.push(['_setDomainName', '.idahobusinessreview.com']);
</script>
<!--
	generated 100 seconds ago
	generated in 1.256 seconds
	served from batcache in 0.014 seconds
	expires in 200 seconds
	Server: dc1web10.dolanmedia.com
-->
</head>
<body id="top" class="single single-post postid-183925 single-format-standard good-works always_free">
	<div class="background-cover"></div>
	<div class="wrapper full-site">
				<div class="top-nav fade-in animated1 head_brnews">
			<div class="container">
				<div class="search-block">
					<form method="get" id="searchform" action="http://idahobusinessreview.com/">
						<button class="search-button" type="submit" value="Search"></button>
						<input type="text" id="s" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}"  />
					</form>
				</div><!-- .search-block /-->
					<div class="social-icons icon_flat">
		<a class="tooldown" title="Rss" href="http://idahobusinessreview.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="tooldown" title="Facebook" href="https://www.facebook.com/IdahoBusinessReview/" target="_blank"><i class="tieicon-facebook"></i></a><a class="tooldown" title="Twitter" href="https://twitter.com/IBRnews" target="_blank"><i class="tieicon-twitter"></i></a><a class="tooldown" title="LinkedIn" href="https://www.linkedin.com/company/idaho-business-review" target="_blank"><i class="tieicon-linkedin"></i></a><a class="tooldown" title="Vimeo" href="https://vimeo.com/channels/idahobusinessreview" target="_blank"><i class="tieicon-vimeo"></i></a><a class="tooldown" title="instagram" href="https://www.instagram.com/idahobusinessreview/" target="_blank"><i class="tieicon-instagram"></i></a><a class="tooldown" title="photo" href="http://www.idahobusinessreview.smugmug.com/" target="_blank"><i class="tieicon-photo"></i></a>	</div>

	
				<div class="top-menu"><ul id="menu-subscribe" class="menu"><li id="menu-item-110371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110371"><a href="https://subscribe.idahobusinessreview.com/">Subscribe</a></li>
<li id="menu-item-110373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110373"><a href="https://subscribe.idahobusinessreview.com/index.cfm?display=login">Manage Account</a></li>
<li><a href="/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/?dmcss=login">LOG IN</a></li></ul></div>	
	<div class="breaking-news">
		<span>Don't Miss</span>
				
					<ul>
							<li><a href="http://idahobusinessreview.com/2016/11/22/boys-girls-clubs-of-ada-county-expands-to-kuna/" title="Boys &#038; Girls Clubs of Ada County expands to Kuna">Boys &#038; Girls Clubs of Ada County expands to Kuna</a></li>
							<li><a href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/" title="Larry H. Miller to Share the Love for the ninth year">Larry H. Miller to Share the Love for the ninth year</a></li>
							<li><a href="http://idahobusinessreview.com/2016/11/22/micron-employees-donate-912-turkeys-and-324-hams/" title="Micron employees donate 912 turkeys and 324 hams">Micron employees donate 912 turkeys and 324 hams</a></li>
							<li><a href="http://idahobusinessreview.com/2016/11/22/realtors-community-foundation-grants-more-than-25000-to-ada-county-nonprofits/" title="Realtors Community Foundation grants more than $25,000 to Ada County nonprofits">Realtors Community Foundation grants more than $25,000 to Ada County nonprofits</a></li>
							<li><a href="http://idahobusinessreview.com/2016/11/22/albertsons-donates-2832-meals-to-idahoans-in-need/" title="Albertsons donates 2,832 meals to Idahoans in need">Albertsons donates 2,832 meals to Idahoans in need</a></li>
							<li><a href="http://idahobusinessreview.com/2016/11/22/michel-bourgeau-and-ross-borden-join-bogus-basin-board/" title="Michel Bourgeau and Ross Borden join Bogus Basin board">Michel Bourgeau and Ross Borden join Bogus Basin board</a></li>
							<li><a href="http://idahobusinessreview.com/2016/11/22/todd-wilson-robert-clancy-promoted-at-d-l-evans-bank-linda-grover-is-senior-loan-assistant/" title="Todd Wilson, Robert Clancy promoted at D.L. Evans Bank; Linda Grover is senior loan assistant">Todd Wilson, Robert Clancy promoted at D.L. Evans Bank; Linda Grover is senior loan assistant</a></li>
							<li><a href="http://idahobusinessreview.com/2016/11/22/state-will-auction-off-several-downtown-boise-commercial-buildings/" title="State will auction off several downtown Boise commercial buildings&nbsp;">State will auction off several downtown Boise commercial buildings&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="http://idahobusinessreview.com/2016/11/22/grove-plaza-has-reopened/" title="Grove Plaza has reopened&nbsp;">Grove Plaza has reopened&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="http://idahobusinessreview.com/2016/11/22/restaurant-researchers-more-red-wine-leads-to-more-desserts/" title="Restaurant researchers: More red wine leads to more desserts">Restaurant researchers: More red wine leads to more desserts</a></li>
						</ul>
					
						<script type="text/javascript">
			jQuery(document).ready(function(){
								jQuery('.breaking-news ul').innerfade({animationtype: 'fade', speed: 750 , timeout: 3500});
							});
		</script>
	</div> <!-- .breaking-news -->				<div class="top-menu-liney" style="display:none;"><a class="top-menu-footer-liney" href="#footer-top-menu-liney"><img src="http://idahobusinessreview.com/wp-content/themes/jarida/images/lineywhite.png"></a></div>
				
			</div>
		</div><!-- .top-menu /-->
		
		<div class="container">
		<header id="theme-header">
		<div class="header-content fade-in animated1">
			<div class="logo" style="margin-top:15px">
			<h2>
																<a title="Idaho Business Review" href="http://idahobusinessreview.com/">
					<img onerror="this.src='/files/2014/03/ibrlogo.png';this.onerror=null;" src="/files/2014/03/ibrlogo.svg" alt="Idaho Business Review" /><strong>Idaho Business Review IBR</strong>
				</a>
			</h2>			</div><!-- .logo /-->
			<div class="e3lan-top">					<div class="openx shortcode" id="top-ad-inner"><img class="close-ad-image" src="/wp-content/themes/jarida/images/solid-close-square.png" />

<!--/* OpenX Javascript Tag v2.5.60-beta */-->

<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ad2.dolanadserver.com/ibr/www/delivery//ajs.php':'http://ad2.dolanadserver.com/ibr/www/delivery//ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=97");
   document.write ('&amp;category=Good Works');
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ad2.dolanadserver.com/ibr/www/delivery//ck.php?n=b5a684&amp;cb=cd2651877c59ee797f21bd949ae57f0a' target='_blank'><img src='http://ad2.dolanadserver.com/ibr/www/delivery//avw.php?zoneid=97&amp;cb=cd2651877c59ee797f21bd949ae57f0a&amp;n=b5a684' border='0' alt='' /></a></noscript>
</div>
				</div>			<div class="clear"></div>
		</div>
									<nav id="main-nav" class="fade-in animated2 fixed-enabled">
				<div class="container">
				<div class="main-menu"><ul id="menu-news" class="menu"><li id="menu-item-109531" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-home"><a href="http://idahobusinessreview.com/">Home</a></li>
<li id="menu-item-109521" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://idahobusinessreview.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-110165" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/news/business-news/">Business News</a></li>
	<li id="menu-item-129934" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/news/construction/">Construction News</a></li>
	<li id="menu-item-129935" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/news/real-estate/">Real Estate News</a></li>
	<li id="menu-item-176103" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/news/roundup/">Roundup</a></li>
	<li id="menu-item-110166" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/commentary/">Commentary</a></li>
	<li id="menu-item-109537" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/breakfast-series/">Breakfast Series</a></li>
	<li id="menu-item-151130" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.com/square-feet/">Square Feet</a></li>
	<li id="menu-item-140308" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/digital-edition/">Digital Edition&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-109532" class="menu-item  menu-item-type-post_type  menu-item-object-page  menu-item-has-children"><a href="http://idahobusinessreview.com/events/">Awards Events &#038; Pubs</a>
<ul class="sub-menu">
	<li id="menu-item-109543" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/woy/">Women of the Year</a></li>
	<li id="menu-item-109535" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/ceo/">CEO of Influence</a></li>
	<li id="menu-item-109541" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/excellence-in-finance/">Excellence in Finance</a></li>
	<li id="menu-item-109533" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/au40/">Accomplished Under 40</a></li>
	<li id="menu-item-109542" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/tp/">Top Projects</a></li>
	<li id="menu-item-110318" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/leaders-in-law/">Leaders in Law</a></li>
	<li id="menu-item-183048" class="menu-item  menu-item-type-post_type  menu-item-object-page  menu-item-has-children"><a href="http://idahobusinessreview.com/events/nominations/">Nomination Forms</a>
	<ul class="sub-menu">
		<li id="menu-item-183046" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/woy/nominate/">Women of the Year</a></li>
		<li id="menu-item-183044" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/ceo/nominate-2/">CEO of Influence</a></li>
		<li id="menu-item-183045" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/au40/nominate/">Accomplished Under 40</a></li>
		<li id="menu-item-183043" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/excellence-in-finance/excellence-in-finance-nominate/">Excellence in Finance</a></li>
		<li id="menu-item-183067" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/tp/top-projects-application/">Top Projects</a></li>
		<li id="menu-item-183041" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/leaders-in-law/nominate-leaders-in-law/">Leaders in Law</a></li>
	</ul> <!--End Sub Menu -->
</li>
	<li id="menu-item-160013" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.com/2016-award-applications/">Awards applications</a></li>
	<li id="menu-item-130416" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://www.idahobusinessreview.smugmug.com">Event Photos</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-130036" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="http://idahobusinessreview.com/specpubs/">Other Publications</a>
<ul class="sub-menu">
	<li id="menu-item-109538" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/bol/">Book of Lists</a></li>
	<li id="menu-item-109536" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/guide/">The Complete Planners&#8217; Guide for All Corporate Events</a></li>
	<li id="menu-item-110312" class="menu-item  menu-item-type-post_type  menu-item-object-page  menu-item-has-children"><a href="http://idahobusinessreview.com/specpubs/welcome-to-boise/">Welcome to Boise</a>
	<ul class="sub-menu">
		<li id="menu-item-110316" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/welcome-to-boise/dining-decisions/">Dining Decisions</a></li>
	</ul> <!--End Sub Menu -->
</li>
	<li id="menu-item-161737" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/downtown-boise-renewal-3/">Downtown Boise Renewal</a></li>
	<li id="menu-item-109540" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/state-of-downtown-boise/">State of Downtown Boise</a></li>
	<li id="menu-item-110317" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/ccim-directory/">CCIM Directory</a></li>
	<li id="menu-item-110313" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/travelog/">Travelog</a></li>
	<li id="menu-item-110315" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/heartland-living/">Idaho Heartland Living</a></li>
	<li id="menu-item-161751" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs/mccall-map/">McCall Map</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-111134" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.com/book-of-lists4">TopLists</a></li>
<li id="menu-item-109527" class="menu-item  menu-item-type-post_type  menu-item-object-page  menu-item-has-children"><a href="http://idahobusinessreview.com/about/advertising/">Advertising</a>
<ul class="sub-menu">
	<li id="menu-item-109529" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/about/advertising/advertising-rates/">Advertising Rates</a></li>
	<li id="menu-item-109530" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/about/advertising/editorial-calendar/">Editorial &#038; Event Calendars</a></li>
	<li id="menu-item-110167" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/about/advertising/readership-information/">Readership Information</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-131281" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="http://idahobusinessreview.com/leads-from-public-records/">Public Notice &#038; Leads</a>
<ul class="sub-menu">
	<li id="menu-item-110984" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://publicnotices.idahobusinessreview.com">Public Notices</a></li>
	<li id="menu-item-130432" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.com/leads/">Leads (pdf)</a></li>
	<li id="menu-item-130436" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.com/leads-from-public-records-xlsx/">Leads (excel)</a></li>
</ul> <!--End Sub Menu -->
</li>
</ul></div>				</div>
			</nav><!-- .main-nav /-->
		</header><!-- #header /-->

	<div id="main-content" class="container fade-in animated3">
<div class="content-wrap">
	<div class="content">
        <div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="http://idahobusinessreview.com"><i class="tieicon-home"></i>Home</a></span> / <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="http://idahobusinessreview.com/category/good-works/">Good Works</a></span> / <span class="current">Larry H. Miller to Share the Love for the ninth year</span></div>		
		
				
						
		<article id="the-post" class="post-listing hnews hentry item post-183925 post type-post status-publish format-standard category-good-works always_free">
				

			<div class="post-inner">
             				<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">Larry H. Miller to Share the Love for the ninth year</span></h1>
                             
						
<p class="post-meta">
		
	<span class="post-meta-author">By:  <a href="http://idahobusinessreview.com/author/ibrstaff/" title="">IBR Staff </a></span>
    	
		
	 <span class="tie-date">November 22, 2016</span>	
	<span class="post-comments"><a href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/#respond">0</a></span>
</p>
<div class="clear"></div>
	
				<div class="entry entry-content">
					
					<p>Larry H. Miller Subaru Boise has selected Big Brothers Big Sisters of Southwest Idaho as their hometown charity to be added to the list of organizations that customers can select to receive a 2016 Subaru Share the Love donation.</p>
<p>Share the Love runs from <span class="aBn" tabindex="0" data-term="goog_1426559760"><span class="aQJ">Nov. 17, 2016 to Jan. 3, 2017</span></span> and allows Subaru dealerships the opportunity to select charities operating in their community to be included in a list of organizations that new owners and lessees can select from to receive a $250 donation from Subaru of America. This year, for the first time, there will be no cap on the total donation from Subaru of America to its Share the Love charitable partners. By the end of this year’s event, Subaru hopes to reach a grand total of nearly $90 million donated since the creation of Share the Love.</p>
<p>In 2015, LHM Subaru Boise donated more than $30,000 to Ride for Joy, a therapeutic riding program, and the Idaho Humane Society. Boise Rescue Mission benefited from a $23,114 donation during the Share the Love campaign in 2014.</p>
<!-- post-single CPT Filter Start --><!-- post-single CPT Filter End    --><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-183925" class="share-facebook sd-button share-icon" href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-183925" class="share-linkedin sd-button share-icon" href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-183925" class="share-twitter sd-button share-icon" href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-183925" class="share-google-plus-1 sd-button share-icon" href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-end"></li></ul></div></div></div>										
					
									</div><!-- .entry /-->
				                <span style="display:none" class="updated" title="2016-11-22T14:57:28Z">2:57 pm Tue, November 22, 2016</span>
                <span class="source-org vcard" style="display:none;"><a class="org fn" href="http://idahobusinessreview.com">Idaho Business Review</a></span>								<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="http://idahobusinessreview.com/author/ibrstaff/" title="Posts by IBR Staff" rel="author">IBR Staff</a></strong></div>
								
								
			</div><!-- .post-inner -->
		</article><!-- .post-listing -->
		        
		
				
						
		<div class="post-navigation">
			<div class="post-previous"><a href="http://idahobusinessreview.com/2016/11/22/micron-employees-donate-912-turkeys-and-324-hams/" rel="prev"><span>Previous:</span> Micron employees donate 912 turkeys and 324 hams</a></div>
			<div class="post-next"><a href="http://idahobusinessreview.com/2016/11/22/boys-girls-clubs-of-ada-county-expands-to-kuna/" rel="next"><span>Next:</span> Boys &#038; Girls Clubs of Ada County expands to Kuna</a></div>
		</div><!-- .post-navigation -->
				
				
		<section id="author-box">
			<div class="block-head">
				<h3>About IBR Staff </h3>
			</div>
			<div class="post-listing">
						<div class="author-avatar">
			<img alt='' src='http://0.gravatar.com/avatar/0633638b408ca148b5deceab7d864a53?s=60&#038;r=pg' srcset='http://0.gravatar.com/avatar/0633638b408ca148b5deceab7d864a53?s=120&amp;r=pg 2x' class='avatar avatar-60 photo' height='60' width='60' />		</div><!-- #author-avatar -->
		<div class="author-description">
			</div><!-- #author-description -->
			<div class="author-social">
							<a class="ttip" href="http://" title="IBR Staff 's site"><img src="http://idahobusinessreview.com/wp-content/themes/jarida/images/author_site.png" width="18" height="18" alt="" /></a>
																																</div>
		<div class="clear"></div>
				</div>
		</section><!-- #author-box -->
		
			

		
                		<div id="comments">



				<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://idahobusinessreview.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<p class="comment-notes">Your email address will not be published. Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <span class="required">*</span><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email</label> <span class="required">*</span><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='183925' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="077f97914a" /></p><div class="g-recaptcha" data-sitekey="6Le2xiMTAAAAAFD40x_ZtsDlPGwfRMUy7mVRR2Ki" data-theme="standard"></div><script type="text/javascript"src="https://www.google.com/recaptcha/api.js?hl=en"></script>            <div id="recaptcha-submit-btn-area">&nbsp;</div>
            <noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="248"/></p>				</form>
					</div><!-- #respond -->
		
</div><!-- #comments -->
        	
	</div><!-- .content -->
<aside class="sidebar-narrow">
			<div id="text-html-widget-13" class="text-html-box" >
			<p><strong>Sign up for the Idaho Business Review email alerts FREE!</strong></p><br>

<style>

.ao_tbl_cell{padding-left: 0px !important; padding-bottom:10px !important;}

.form_0028_ao_submit_button{float:left;}

</style>

<script src="/wp-content/plugins/dmc-bluesky-embed/js/actonbluesky.js"></script><!-- ======================================================================================= -->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<link rel="stylesheet" type="text/css" href="//news.thedolancompany.com/acton/formNegCap.css">
<script type="text/javascript" src="//news.thedolancompany.com/acton/form/20728/0028/form.js">
</script>
<!-- ======================================================================================= -->
<!-- place exactly one copy of everything above these lines in the head section of your page -->
<!-- place everything below these lines in the body section of your page -->
<!-- ======================================================================================= -->
<form id="form_0028" method="post" enctype="multipart/form-data" action="//news.thedolancompany.com/acton/forms/userSubmit.jsp" accept-charset="UTF-8" target="_self">
<input type="hidden" name="ao_a" value="20728" >
<input type="hidden" name="ao_f" value="0028" >
<input type="hidden" name="ao_d" value="0028:d-0001" >
<input type="hidden" name="ao_p" id="ao_p" value="0" >
<input type="hidden" name="ao_jstzo" id="ao_jstzo" value="" >
<input type="hidden" name="ao_cuid" value="" >
<input type="hidden" name="ao_srcid" value="" >
<input type="hidden" name="ao_bot" id="ao_bot" value="yes" >
<input type="hidden" name="ao_camp" value="" >
<link rel="stylesheet" type="text/css" href="//news.thedolancompany.com/acton/form/20728/0028/form.css">
<div id="ao_alignment_container" class="aoFormContainer" align="center">
<table class="ao_tbl_container" border="0" cellspacing="0" cellpadding="0" style="margin-top:-10px;">
<tr>
<td class="ao_tbl_cell" style="padding-left: 10px; " align="center">
<div align="left">
<div class="formField">
<div class="formFieldLabel" id="form_0028_fld_0-Label">
<label for = "form_0028_fld_0">
Email Address</label>
<b style="color: #FF0000; cursor: default" title="Required Field">
*</b>
</div>
<input type="text" class="formFieldText formFieldMedium" id="form_0028_fld_0" name="email" onBlur="singleCheck ('form_0028_fld_0', 'EMAIL', 'form_0028_fld_0-Label')">
</div>
<script type="text/javascript">
if (typeof(addRequiredField) != 'undefined') { addRequiredField ('form_0028_fld_0'); } </script>
<script type="text/javascript">
if (typeof(addFieldToValidate) != 'undefined') { addFieldToValidate ('form_0028_fld_0', 'EMAIL'); } </script>
</div>
</td>
</tr>
<tr>
<td class="ao_tbl_cell" style="padding-left: 10px; padding-right: 10px" align="center">
<div align="left">
<input type="hidden" id="form_0028_fld_1" name="IBR Daily Alert" value="yes">
</div>
</td>
</tr>
<tr>
<td class="ao_tbl_cell" style="padding-left: 10px; padding-right: 10px" align="center">
<div align="left">
<input type="hidden" id="form_0028_fld_2" name="Source" value="website">
</div>
</td>
</tr>
<tr>
<td class="ao_tbl_cell" style="padding-left: 10px; padding-right: 10px" align="center">
<div align="left">
<input type="hidden" id="form_0028_fld_3" name="IBR CircMktg Alert" value="yes">
</div>
</td>
</tr>
<input type="hidden" id="form_0028_fld_4" name="Special Offers from Select Partners" value="true">
<!-- BUTTONS -->
<tr>
<td style="margin-top:-30px;" align="center" id="form_0028_ao_submit_button">
<a id="form_0028_ao_submit_href" href="javascript: doSubmit(document.getElementById('form_0028'))">
<img src="http://news.thedolancompany.com/cdnr/46/acton/attachment/20728/f-0090/1/-/-/-/-/image.png" border="0">
</a>
</td>
</tr>
<tr class="formNegCap">
<td>
<input type="text" id="ao_form_neg_cap" name="ao_form_neg_cap" value="">
</td>
</tr>
</table>
</div>
<img src='//news.thedolancompany.com/acton/form/20728/0028:d-0001/pgend.gif' width='1' height='1'>
</form>			</div>
		<div id="categort-posts-widget-8" class="widget categort-posts"><div class="widget-top"><h4><a href="http://idahobusinessreview.com/category/people/">People</a>		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li>
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2016/11/22/michel-bourgeau-and-ross-borden-join-bogus-basin-board/" title="Permalink to Michel Bourgeau and Ross Borden join Bogus Basin board" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2016/11/Ross-Borden_small_portrait-1-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="ross-borden_small_portrait" srcset="http://idahobusinessreview.com/files/2016/11/Ross-Borden_small_portrait-1-70x70.jpg 70w, http://idahobusinessreview.com/files/2016/11/Ross-Borden_small_portrait-1-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2016/11/22/michel-bourgeau-and-ross-borden-join-bogus-basin-board/">Michel Bourgeau and Ross Borden join Bogus Basin board</a></h3>
			 <span class="date"><span class="tie-date">November 22, 2016</span></span>
		</li>
			<li>
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2016/11/22/todd-wilson-robert-clancy-promoted-at-d-l-evans-bank-linda-grover-is-senior-loan-assistant/" title="Permalink to Todd Wilson, Robert Clancy promoted at D.L. Evans Bank; Linda Grover is senior loan assistant" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2016/11/Linda-Grover-1-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="linda-grover" srcset="http://idahobusinessreview.com/files/2016/11/Linda-Grover-1-70x70.jpg 70w, http://idahobusinessreview.com/files/2016/11/Linda-Grover-1-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2016/11/22/todd-wilson-robert-clancy-promoted-at-d-l-evans-bank-linda-grover-is-senior-loan-assistant/">Todd Wilson, Robert Clancy promoted at D.L. Evans Bank; Linda Grover is senior loan assistant</a></h3>
			 <span class="date"><span class="tie-date">November 22, 2016</span></span>
		</li>
			<li>
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2016/11/21/idaho-humanities-council-welcomes-four-new-board-members/" title="Permalink to Idaho Humanities Council welcomes four new board members" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2016/11/Andrea-Partington-1-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="andrea-partington" srcset="http://idahobusinessreview.com/files/2016/11/Andrea-Partington-1-70x70.jpg 70w, http://idahobusinessreview.com/files/2016/11/Andrea-Partington-1-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2016/11/21/idaho-humanities-council-welcomes-four-new-board-members/">Idaho Humanities Council welcomes four new board members</a></h3>
			 <span class="date"><span class="tie-date">November 21, 2016</span></span>
		</li>
			<li>
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2016/11/21/three-join-board-of-st-lukes-health-system/" title="Permalink to Three join board of St. Luke&#8217;s Health System" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2016/11/Lisa-Grow-1-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="lisa-grow" srcset="http://idahobusinessreview.com/files/2016/11/Lisa-Grow-1-70x70.jpg 70w, http://idahobusinessreview.com/files/2016/11/Lisa-Grow-1-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2016/11/21/three-join-board-of-st-lukes-health-system/">Three join board of St. Luke&#8217;s Health System</a></h3>
			 <span class="date"><span class="tie-date">November 21, 2016</span></span>
		</li>
			<li>
						<h3><a href="http://idahobusinessreview.com/2016/11/18/kendra-kenyon-joins-advocates-for-the-west/">Kendra Kenyon joins Advocates for the West</a></h3>
			 <span class="date"><span class="tie-date">November 18, 2016</span></span>
		</li>
		
				</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /--><div id="categort-posts-widget-9" class="widget categort-posts"><div class="widget-top"><h4><a href="http://idahobusinessreview.com/category/top-stories/">Top Stories</a>		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li>
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2016/11/22/state-will-auction-off-several-downtown-boise-commercial-buildings/" title="Permalink to State will auction off several downtown Boise commercial buildings&nbsp;" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2016/11/state-building-auction-web-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Three in a row: The state-owned 10 Barrel Brewing building and the neighboring parking lot and Garro Building will be auctioned Dec. 1 along with a few other Boise and Idaho Falls commercial buildings. Photo by Teya Vitu." srcset="http://idahobusinessreview.com/files/2016/11/state-building-auction-web-70x70.jpg 70w, http://idahobusinessreview.com/files/2016/11/state-building-auction-web-200x200.jpg 200w, http://idahobusinessreview.com/files/2016/11/state-building-auction-web-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2016/11/22/state-will-auction-off-several-downtown-boise-commercial-buildings/">State will auction off several downtown Boise commercial buildings&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">November 22, 2016</span></span>
		</li>
			<li>
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2016/11/22/grove-plaza-has-reopened/" title="Permalink to Grove Plaza has reopened&nbsp;" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2016/11/grove-plaza-1-web-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="A new Grove Plaza opened surrounded by a new Boise Centre East and Clearwater Building. Photo by Teya Vitu." srcset="http://idahobusinessreview.com/files/2016/11/grove-plaza-1-web-70x70.jpg 70w, http://idahobusinessreview.com/files/2016/11/grove-plaza-1-web-200x200.jpg 200w, http://idahobusinessreview.com/files/2016/11/grove-plaza-1-web-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2016/11/22/grove-plaza-has-reopened/">Grove Plaza has reopened&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">November 22, 2016</span></span>
		</li>
			<li>
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2016/11/22/restaurant-researchers-more-red-wine-leads-to-more-desserts/" title="Permalink to Restaurant researchers: More red wine leads to more desserts" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2013/08/Wine-Friendly-WEB.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Wine Friendly WEB" srcset="http://idahobusinessreview.com/files/2013/08/Wine-Friendly-WEB.jpg 1296w, http://idahobusinessreview.com/files/2013/08/Wine-Friendly-WEB-110x110.jpg 110w, http://idahobusinessreview.com/files/2013/08/Wine-Friendly-WEB-300x300.jpg 300w, http://idahobusinessreview.com/files/2013/08/Wine-Friendly-WEB-1024x1024.jpg 1024w, http://idahobusinessreview.com/files/2013/08/Wine-Friendly-WEB-92x92.jpg 92w, http://idahobusinessreview.com/files/2013/08/Wine-Friendly-WEB-200x200.jpg 200w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2016/11/22/restaurant-researchers-more-red-wine-leads-to-more-desserts/">Restaurant researchers: More red wine leads to more desserts</a></h3>
			 <span class="date"><span class="tie-date">November 22, 2016</span></span>
		</li>
			<li>
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2016/11/22/idahos-noncompete-law-bucks-a-national-trend/" title="Permalink to Idaho&#8217;s noncompete law bucks a national trend&nbsp;" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2016/11/workers-cropped-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Workers talking in an office building." srcset="http://idahobusinessreview.com/files/2016/11/workers-cropped-70x70.jpg 70w, http://idahobusinessreview.com/files/2016/11/workers-cropped-200x200.jpg 200w, http://idahobusinessreview.com/files/2016/11/workers-cropped-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2016/11/22/idahos-noncompete-law-bucks-a-national-trend/">Idaho&#8217;s noncompete law bucks a national trend&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">November 22, 2016</span></span>
		</li>
			<li>
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2016/11/22/new-time-tracking-app-helps-businesses-save-on-insurance/" title="Permalink to New time tracking app helps businesses save on insurance&nbsp;" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2016/11/lineman-3-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Kene Sperry" srcset="http://idahobusinessreview.com/files/2016/11/lineman-3-70x70.jpg 70w, http://idahobusinessreview.com/files/2016/11/lineman-3-200x200.jpg 200w, http://idahobusinessreview.com/files/2016/11/lineman-3-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2016/11/22/new-time-tracking-app-helps-businesses-save-on-insurance/">New time tracking app helps businesses save on insurance&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">November 22, 2016</span></span>
		</li>
		
				</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /--><div id="dmc-post-feed-10" class="widget widget_dmc-post-feed"><div class="widget-container"><div class="widget-top"><h4> </h4></div>
<div><span style="font-size: x-small;">Our best, right now.</span><ul><li><a href="http://idahobusinessreview.com/2016/11/04/low-key-high-tech-ibr-breakfast-series-report/?ep=1"><strong style="font-size: x-small;">Low key & high tech: IBR Breakfast Series report</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Dani Grigg |</span> <span style="font-size: xx-small; color: #cccccc;">Nov. 4</span></li><li><a href="http://idahobusinessreview.com/2016/10/11/largest-valley-country-store-is-under-construction-in-jerome/?ep=1"><strong style="font-size: x-small;">Largest Valley Country Store is under construction in Jerome</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Teya Vitu |</span> <span style="font-size: xx-small; color: #cccccc;">Oct. 11</span></li><li><a href="http://idahobusinessreview.com/2016/10/06/osteopathic-college-is-on-track-for-february-groundbreaking/?ep=1"><strong style="font-size: x-small;">Osteopathic college is on track for February groundbreaking</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Sharon Fisher |</span> <span style="font-size: xx-small; color: #cccccc;">Oct. 6</span></li><li><a href="http://idahobusinessreview.com/2016/10/05/2-families-look-for-changes-in-law-after-losing-cabins-in-state-auction/?ep=1"><strong style="font-size: x-small;">2 families look for changes in law after losing cabins in state auction</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Benton Alexander Smith |</span> <span style="font-size: xx-small; color: #cccccc;">Oct. 5</span></li><li><a href="http://idahobusinessreview.com/2016/09/22/idaho-has-been-a-lead-state-for-20-years-with-its-construction-gdp/?ep=1"><strong style="font-size: x-small;">Idaho leads in construction as share of GDP</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Teya Vitu |</span> <span style="font-size: xx-small; color: #cccccc;">Sep. 22</span></li></ul> </div></div></div><!-- .widget /--></aside>
</div> <!-- .content-wrap -->
<aside class="sidebar">
<div id="social-9" class="widget social-icons-widget"><div class="widget-top"><h4>Follow IBR</h4><div class="stripe-line"></div></div>
						<div class="widget-container">	<div class="social-icons icon_32">
		<a class="ttip" title="Rss" href="http://idahobusinessreview.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="ttip" title="Facebook" href="https://www.facebook.com/IdahoBusinessReview/" target="_blank"><i class="tieicon-facebook"></i></a><a class="ttip" title="Twitter" href="https://twitter.com/IBRnews" target="_blank"><i class="tieicon-twitter"></i></a><a class="ttip" title="LinkedIn" href="https://www.linkedin.com/company/idaho-business-review" target="_blank"><i class="tieicon-linkedin"></i></a><a class="ttip" title="Vimeo" href="https://vimeo.com/channels/idahobusinessreview" target="_blank"><i class="tieicon-vimeo"></i></a><a class="ttip" title="instagram" href="https://www.instagram.com/idahobusinessreview/" target="_blank"><i class="tieicon-instagram"></i></a><a class="ttip" title="photo" href="http://www.idahobusinessreview.smugmug.com/" target="_blank"><i class="tieicon-photo"></i></a>	</div>

	</div></div><!-- .widget /--><div id="dmc_openx-1082297721" class="widget widget_dmc_openx"><div id="open-x" align="left" style="padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;"><div class="widget-container">

<!--/* OpenX Javascript Tag v2.5.60-beta */-->

<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ad2.dolanadserver.com/ibr/www/delivery//ajs.php':'http://ad2.dolanadserver.com/ibr/www/delivery//ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=155");
   document.write ('&amp;category=Good Works');
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ad2.dolanadserver.com/ibr/www/delivery//ck.php?n=e1bd50&amp;cb=9cbf202f354dc330cef930b9f93a937d' target='_blank'><img src='http://ad2.dolanadserver.com/ibr/www/delivery//avw.php?zoneid=155&amp;cb=9cbf202f354dc330cef930b9f93a937d&amp;n=e1bd50' border='0' alt='' /></a></noscript>
</div></div></div><!-- .widget /--><div id="dmc_openx-873298766" class="widget widget_dmc_openx"><div id="open-x" align="left" style="padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;"><div class="widget-container">

<!--/* OpenX Javascript Tag v2.5.60-beta */-->

<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ad2.dolanadserver.com/ibr/www/delivery//ajs.php':'http://ad2.dolanadserver.com/ibr/www/delivery//ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=148");
   document.write ('&amp;category=Good Works');
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ad2.dolanadserver.com/ibr/www/delivery//ck.php?n=374c48&amp;cb=4cdb5dcc958aa4ed08ef395526d6ad63' target='_blank'><img src='http://ad2.dolanadserver.com/ibr/www/delivery//avw.php?zoneid=148&amp;cb=4cdb5dcc958aa4ed08ef395526d6ad63&amp;n=374c48' border='0' alt='' /></a></noscript>
</div></div></div><!-- .widget /--><div id="dmc-post-feed-3" class="widget widget_dmc-post-feed"><div class="widget-container"><div class="digital-edition">
<div class="widget-top ">
<h4><a href="/digital-edition/"><a href="http://idahobusinessreview.com/category/digital-edition/">Digital Edition</a></a></h4>
</div><a href="/digital-edition/"><img width="150" height="232" src="http://idahobusinessreview.com/files/2016/11/thumb_131238138076623299_IBR_111816Web00001.jpg" class="attachment-medium size-medium wp-post-image" alt="thumb_131238138076623299_ibr_111816web00001" srcset="http://idahobusinessreview.com/files/2016/11/thumb_131238138076623299_IBR_111816Web00001.jpg 150w, http://idahobusinessreview.com/files/2016/11/thumb_131238138076623299_IBR_111816Web00001-113x175.jpg 113w" sizes="(max-width: 150px) 100vw, 150px" /></a>
<p>The Digital Edition of Idaho Business News is available to both print and online subscribers.</p>
<p><a href="/digital-edition/"><strong>Current edition</strong></a></p></div></div></div><!-- .widget /--><div id="dmc_openx-1082297705" class="widget widget_dmc_openx"><div id="open-x" align="left" style="padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;"><div class="widget-container"></div></div></div><!-- .widget /--><div id="facebook-widget-2" class="widget facebook-widget"><div class="widget-top"><h4>Find us on Facebook		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="facebook-box">
				<iframe src="http://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/IdahoBusinessReview&amp;width=300&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->		<style>

.sidebar-narrow .ao_tbl_cell{
padding-left:0px !Important;
padding-bottom:2px;
}
.sidebar-narrow #form_0028_ao_submit_button{float:left;}

</style>		</aside>
<div class="clear"></div>		<div class="clear"></div>
	</div><!-- .container /-->

		</div><!-- .container -->

	<footer class="fade-in animated4">
	<div id="footer-widget-area" class="footer-3c container">

			<div id="footer-first" class="footer-widgets-box">
			<div id="text-html-widget-2" class="footer-widget text-html"><div class="footer-widget-top"><h4>My Account</h4></div>
						<div class="footer-widget-container"><div ><ul id="footer-top-menu-liney">

<li>
<a href="/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/?dmcss=login">LOG IN</a>
</li>
<li>
<a href="https://subscribe.idahobusinessreview.com/index.cfm">SUBSCRIBE</a>
</li>
<li>
<a href="https://subscribe.idahobusinessreview.com/index.cfm?display=login">MANAGE ACCOUNT</a>
</li>
<li>
<a href="http://bridgetowermedia.com/privacy-policy/">PRIVACY POLICY</a>
</li>
<li>
<a href="http://bridgetowermedia.com/subscriber-agreement/">SUBSCRIBER AGREEMENT</a>
</li>
</ul>
				</div><div class="clear"></div></div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
					<div id="recent-posts-nocache-2" class="footer-widget widget_recent_entries_nocache">		<div class="footer-widget-top"><h4>Recent Posts</h4></div>
						<div class="footer-widget-container">		<ul>
					<li>
				<a href="http://idahobusinessreview.com/2016/11/22/boys-girls-clubs-of-ada-county-expands-to-kuna/" title="Boys &#038; Girls Clubs of Ada County expands to Kuna">Boys &#038; Girls Clubs of Ada County expands to Kuna</a>
						</li>
					<li>
				<a href="http://idahobusinessreview.com/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/" title="Larry H. Miller to Share the Love for the ninth year">Larry H. Miller to Share the Love for the ninth year</a>
						</li>
					<li>
				<a href="http://idahobusinessreview.com/2016/11/22/micron-employees-donate-912-turkeys-and-324-hams/" title="Micron employees donate 912 turkeys and 324 hams">Micron employees donate 912 turkeys and 324 hams</a>
						</li>
					<li>
				<a href="http://idahobusinessreview.com/2016/11/22/realtors-community-foundation-grants-more-than-25000-to-ada-county-nonprofits/" title="Realtors Community Foundation grants more than $25,000 to Ada County nonprofits">Realtors Community Foundation grants more than $25,000 to Ada County nonprofits</a>
						</li>
					<li>
				<a href="http://idahobusinessreview.com/2016/11/22/albertsons-donates-2832-meals-to-idahoans-in-need/" title="Albertsons donates 2,832 meals to Idahoans in need">Albertsons donates 2,832 meals to Idahoans in need</a>
						</li>
				</ul>
		</div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

			<div id="footer-third" class="footer-widgets-box">
			<div id="text-html-widget-6" class="footer-widget text-html"><div class="footer-widget-top"><h4>Idaho Business Review</h4></div>
						<div class="footer-widget-container"><div ><ul>
<li>
<a href="/about/">ABOUT US</a>
</li>
<li>
<a href="/advertising/">ADVERTISING</a>
</li>
<li>
<a href="/contact-us/">CONTACT US</a>
</li>
<li>
<a href="/frequently-asked-questions/">FREQUENTLY ASKED QUESTIONS</a>
</li>
<li>
<a href="/specpubs/">OUR PUBLICATIONS</a>
</li>
<li>
<a href="/business-announcements/">SUBMIT BUSINESS ANNOUNCEMENTS</a>
</li>

</ul>
<p></p>
				</div><div class="clear"></div></div></div><!-- .widget /-->		</div><!-- #third .widget-area -->
	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
	<div class="clear"></div>
	<div class="footer-bottom fade-in animated4">
		<div class="container">
				<div class="social-icons icon_flat">
		<a class="ttip" title="Rss" href="http://idahobusinessreview.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="ttip" title="Facebook" href="https://www.facebook.com/IdahoBusinessReview/" target="_blank"><i class="tieicon-facebook"></i></a><a class="ttip" title="Twitter" href="https://twitter.com/IBRnews" target="_blank"><i class="tieicon-twitter"></i></a><a class="ttip" title="LinkedIn" href="https://www.linkedin.com/company/idaho-business-review" target="_blank"><i class="tieicon-linkedin"></i></a><a class="ttip" title="Vimeo" href="https://vimeo.com/channels/idahobusinessreview" target="_blank"><i class="tieicon-vimeo"></i></a><a class="ttip" title="instagram" href="https://www.instagram.com/idahobusinessreview/" target="_blank"><i class="tieicon-instagram"></i></a><a class="ttip" title="photo" href="http://www.idahobusinessreview.smugmug.com/" target="_blank"><i class="tieicon-photo"></i></a>	</div>

				<div class="alignleft">
			<span class="four_fifth" style="display: inline-block;text-align: center;line-height: 16px;"><span style="white-space:nowrap;">Copyright © 2016</span> <span class="vcard"><span class="fn n org" style="white-space:nowrap;">Idaho Business Review</span></span> | <span class="adr"><span class="street-address" style="white-space:nowrap;">855 W. Broad Street, Suite 103</span>, <span  style="white-space:nowrap;"><span class="locality">Boise</span>, <span class="region">ID</span> <span class="postal-code">83702</span></span></span> | <a href="tel:(208) 336-3768" style="white-space:nowrap;">Phone: (208) 336-3768</a> <a href="fax:(208) 336-5534" style="white-space:nowrap;">Fax: (208) 336-5534</a></span></span>
<span class="one_fifth_last"><a href="http://bridgetowermedia.com" style="max-width:140px;"><img alt="bridge tower media logo" src="http://bridgetowermedia.com/files/2016/08/btmlogo140.svg" onerror="this.onerror=null; this.src='http://bridgetowermedia.com/files/2016/08/btmlogo140.png'" scale="0" data-pin-nopin="true" style="max-width:140px;width:100%;"></a></span>
			</div>
		</div><!-- .Container -->
	</div><!-- .Footer bottom -->

</div><!-- .Wrapper -->
	<div id="topcontrol" class="tieicon-up-open" title="Scroll To Top"></div>
<div id="fb-root"></div>
	<div style="display:none">
	<div class="grofile-hash-map-0633638b408ca148b5deceab7d864a53">
	</div>
	</div>
<script type="text/javascript">
jQuery(".close-ad-image").click(function() {
    jQuery(this).parent().hide();
});

jQuery(document).ready(function($){
  
	$(".top-menu-footer-liney").click(function(event){
    
		event.preventDefault();
    
		var offset = $($(this).attr('href')).offset().top;
	
		offset = offset - 200;
    
		$('html, body').animate({scrollTop:offset}, 3000);
  
	});

});
</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/idahobusinessreview.com\/2016\/11\/22\/larry-h-miller-to-share-the-love-for-the-ninth-year\/":183925};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2016/11/22/larry-h-miller-to-share-the-love-for-the-ninth-year/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			
			<img style="float: right; display: none" class="loading" src="http://idahobusinessreview.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
		            <script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/mu-plugins/mkt/mkt.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/idahobusinessreview.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/wp-polls/polls-js.js'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/jetpack/modules/wpgroho.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"go_to":"Go to...","ajaxurl":"http:\/\/idahobusinessreview.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","is_singular":"1","reading_indicator":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/themes/jarida/js/tie-scripts.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201647.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.0.3',blog:'43766312',post:'183925',tz:'-7',srv:'idahobusinessreview.com'} ]);
	_stq.push([ 'clickTrackerInit', '43766312', '183925' ]);
</script>
</body>
</html>