<!DOCTYPE html>
<html lang="en-US" xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://idahobusinessreview.com/xmlrpc.php" />
<title>Israel Catz joins Lee Pesky Center &#8211; Idaho Business Review</title>

<!-- Google Tag Manager for WordPress by DuracellTomi - http://duracelltomi.com -->
<script data-cfasync="false" type="text/javascript">
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || []
</script>
<!-- End Google Tag Manager for WordPress by DuracellTomi -->
<!-- All in One SEO Pack 2.3.10.2 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<link rel="canonical" href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//a.optnmnstr.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Idaho Business Review &raquo; Feed" href="http://idahobusinessreview.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Idaho Business Review &raquo; Comments Feed" href="http://idahobusinessreview.com/comments/feed/" />
<meta name="apple-mobile-web-app-title" content="  Israel Catz joins Lee Pesky Center">
<link rel="apple-touch-icon" sizes="57x57" href="http://idahobusinessreview.com/files/2014/03/1br57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="http://idahobusinessreview.com/files/2014/03/1br72.png" />
<link rel="apple-touch-icon" sizes="114x114" href="http://idahobusinessreview.com/files/2014/03/1br114.png" />
<link rel="apple-touch-icon" sizes="144x144" href="http://idahobusinessreview.com/files/2014/03/1br144.png" />
<meta name='thumbnail' content='http://idahobusinessreview.com/files/2017/06/Israel-Catz-180x120.jpg' />
<link rel="alternate" type="application/rss+xml" title="Idaho Business Review &raquo; Israel Catz joins Lee Pesky Center Comments Feed" href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/feed/" />
<link rel='stylesheet' id='wp-polls-css'  href='http://idahobusinessreview.com/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://idahobusinessreview.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='tie-style-css'  href='http://idahobusinessreview.com/wp-content/themes/jarida/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='mobilemenu-css'  href='http://idahobusinessreview.com/wp-content/themes/jarida/css/mobilemenu.css' type='text/css' media='all' />
<link rel='stylesheet' id='Oswald-css'  href='http://fonts.googleapis.com/css?family=Oswald%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://idahobusinessreview.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css' type='text/css' media='all' />
<link rel='stylesheet' id='site_nonspecific-css'  href='http://idahobusinessreview.com/wp-content/mu-plugins/site_css/common.css' type='text/css' media='all' />
<link rel='stylesheet' id='j_idahobusinessreview-css'  href='http://idahobusinessreview.com/wp-content/mu-plugins/site_css/idahobusinessreview/1/j_idahobusinessreview.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://idahobusinessreview.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='dmcssStylesheet-css'  href='http://idahobusinessreview.com/wp-content/plugins/tdc-paywall/style.css' type='text/css' media='all' />
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/mu-plugins/mkt/mkt_header.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/tdc-paywall/login_form.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" src='//a.optnmnstr.com/app/js/api.min.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/google-analyticator/external-tracking.min.js'></script>
<link rel='https://api.w.org/' href='http://idahobusinessreview.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://idahobusinessreview.com/xmlrpc.php?rsd" />
<link rel='prev' title='Idaho Labor Department: State population to near 2M by 2025' href='http://idahobusinessreview.com/2017/06/05/idaho-labor-department-state-population-to-near-2m-by-2025/' />
<link rel='next' title='Jim Beitz to manage Eastern Idaho branch for Foodbank' href='http://idahobusinessreview.com/2017/06/05/jim-beitz-to-manage-eastern-idaho-branch-for-foodbank/' />
<link rel='shortlink' href='http://wp.me/p2XDCg-PaS' />
<link rel="alternate" type="application/json+oembed" href="http://idahobusinessreview.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fidahobusinessreview.com%2F2017%2F06%2F05%2Fisrael-catz-joins-lee-pesky-center%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://idahobusinessreview.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fidahobusinessreview.com%2F2017%2F06%2F05%2Fisrael-catz-joins-lee-pesky-center%2F&#038;format=xml" />

<meta name='google-site-verification' content='pdIfxBOwt8N_Zpc5UZ3AIrXpeYa5v0h0Jnr8IiS1W-A' />
<meta name='y_key' content='877cbb0bd73c44cd' />
<meta name='msvalidate.01' content='3999BB2D894623F4AF6815FACA6133D9' />
<meta name="generator" content="WordPress" /><!-- START Quantcast By WP-Plugin: Quantcast-Quantifier http://wordpress.org/extend/plugins/quantcast-quantifier/ -->
<!-- Start Quantcast tag -->
<script type="text/javascript">
_qoptions={
qacct:"p-29W-admf9poxY", 
labels:"Business"
};
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
<noscript>
<img src="http://pixel.quantserve.com/pixel/p-29W-admf9poxY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>
<!-- End Quantcast tag -->

<script type="text/javascript">
    __compete_code = '0406a660fcef05313cf19e49a64a9f9b';
    (function () {
        var s = document.createElement('script'),
            e = document.getElementsByTagName('script')[0],
            t = document.location.protocol.toLowerCase() === 'https:' ?
                'https://c.compete.com/bootstrap/' :
                'http://c.compete.com/bootstrap/';
            s.src = t + __compete_code + '/bootstrap.js';
            s.type = 'text/javascript';
            s.async = true;
            if (e) { e.parentNode.insertBefore(s, e); }
        }());
</script>

<!-- END Quantcast-Quantifier --><style>.post-thumbnail img[src$='.svg'] { width: 100%; height: auto; }</style>
<meta name="author" content="IBR Staff" />
<link rel="shortcut icon" href="/files/2014/03/1br17.png" title="Favicon" /><!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="http://idahobusinessreview.com/wp-content/themes/jarida/js/html5.js"></script>
<script src="http://idahobusinessreview.com/wp-content/themes/jarida/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="http://idahobusinessreview.com/wp-content/themes/jarida/css/ie8.css" />
<![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<style type="text/css" media="screen">

body{
}

body{
	font-size : 13px !important;
}

.page-title{
	font-weight: bold !important;
	font-style: normal !important;
}
	#main-nav ul li.current-menu-item a,
	#main-nav ul li.current-menu-item a:hover,
	#main-nav ul li.current-menu-parent a,
	#main-nav ul li.current-menu-parent a:hover,
	#main-nav ul li.current-page-ancestor a,
	#main-nav ul li.current-page-ancestor a:hover,
	.pagination span.current,
	.ei-slider-thumbs li.ei-slider-element,
	.breaking-news span,
	.ei-title h2,h2.cat-box-title,
	a.more-link,.scroll-nav a,
	.flex-direction-nav a,
	.tagcloud a:hover,
	#tabbed-widget ul.tabs li.active a,
	.slider-caption h2, .full-width .content .slider-caption h2,
	.review-percentage .review-item span span,.review-final-score,
	.woocommerce span.onsale, .woocommerce-page span.onsale ,
	.woocommerce .widget_price_filter .ui-slider .ui-slider-handle, .woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
	.button,a.button,#main-content input[type="submit"],#main-content input[type="submit"]:focus, span.onsale,
	.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
	#reading-position-indicator {
		background-color:#0071BB !important;
	}
	::-webkit-scrollbar-thumb{background-color:#0071BB !important;}
	#main-nav,.top-nav {border-bottom-color: #0071BB;}
	.cat-box , .footer-bottom .container{border-top-color: #0071BB;}
	.page-head.category-template{border-color: #0071BB !important;}
a {
	color: #4d5054;	}
a:hover {
	color: #000000;	text-decoration: underline;}
::-moz-selection { background: #0071BB;}
::selection { background: #0071BB; }
#main-nav, #main-nav ul ul, #main-nav ul li.mega-menu .mega-menu-block {background-color:#D8D8BA !important;;}
#main-nav ul li a , #main-nav ul ul a , #main-nav ul.sub-menu a {
	color: #000000 !important;	text-shadow: 0 1px 1px #D8D8BA !important;}
#main-nav ul li a:hover, #main-nav ul li:hover > a, #main-nav ul :hover > a , #main-nav  ul ul li:hover > a, #main-nav  ul ul :hover > a  {
	color: #454445 !important;	}
#main-nav ul li.current-menu-item a  {
	color: #ffffff !important;	}
#main-nav ul li {
	border-color: #ffffff;
}
#main-nav ul ul li, #main-nav ul ul li:first-child {
	border-top-color: #ffffff;
}
#main-nav ul li a {
	border-left-color: #ffffff;
}
#main-nav ul ul li, #main-nav ul ul li:first-child {
	border-bottom-color: #ffffff;
}

body.single .post .entry a, body.page .post .entry a {
	color: #2E6EB7;	}
body.single .post .entry a:hover, body.page .post .entry a:hover {
	color: #000000;	text-decoration: underline;}
#flexslider .dmcss_key_icon img, #ei-slider .dmcss_key_icon img {
    display: inline !important;
    height: 1em !important;
    width: auto !important;
}

</style>


<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Israel Catz joins Lee Pesky Center" />
<meta property="og:url" content="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/" />
<meta property="og:description" content="Israel Catz has been named the next executive director of the Lee Pesky Learning Center in Boise. The existing executive director, Evelyn Johnson, has assumed the newly created role of scientific d…" />
<meta property="article:published_time" content="2017-06-05T21:25:50+00:00" />
<meta property="article:modified_time" content="2017-06-05T21:25:50+00:00" />
<meta property="og:site_name" content="Idaho Business Review" />
<meta property="og:image" content="http://idahobusinessreview.com/files/2017/06/Israel-Catz.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="428" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://idahobusinessreview.com/files/2017/06/Israel-Catz.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<!-- Start of Act On Beacon Code -->
<script>/*<![CDATA[*/(function(w,a,b,d,s){w[a]=w[a]||{};w[a][b]=w[a][b]||{q:[],track:function(r,e,t){this.q.push({r:r,e:e,t:t||+new Date});}};var e=d.createElement(s);var f=d.getElementsByTagName(s)[0];e.async=1;e.src='//news.idahobusinessreview.com/cdnr/50/acton/bn/tracker/22733';f.parentNode.insertBefore(e,f);})(window,'ActOn','Beacon',document,'script');ActOn.Beacon.track();/*]]>*/</script>
<!-- End of Act On Beacon Code -->
<!-- Google Analytics Tracking by Google Analyticator 6.5.0: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'disabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-10379233-4', 'auto');
 
	ga('send', 'pageview');
	_gaq.push(['_setDomainName', '.idahobusinessreview.com']);
</script>

<!-- Google Tag Manager for WordPress by DuracellTomi -->
<script data-cfasync="false" type="text/javascript">
	dataLayer.push({"pagePostType":"post","pagePostType2":"single-post","pageCategory":["people"],"pagePostAuthor":"IBR Staff"});
</script><!--
	generated in 0.886 seconds
	88127 bytes batcached for 300 seconds
-->
</head>
<body id="top" class="single single-post postid-196718 single-format-standard people always_free ">
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PK6J63"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script data-cfasync="false">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK6J63');</script>
<!-- End Google Tag Manager --><br style="display:none;">
	<div class="background-cover"></div>
	<div class="wrapper full-site">
				<div class="top-nav fade-in animated1 head_brnews">
			<div class="container">
				<div class="search-block">
					<form method="get" id="searchform" action="http://idahobusinessreview.com/">
						<button class="search-button" type="submit" value="Search"></button>
						<input type="text" id="s" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}"  />
					</form>
				</div><!-- .search-block /-->
					<div class="social-icons icon_flat">
		<a class="tooldown" title="Rss" href="http://idahobusinessreview.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="tooldown" title="Facebook" href="https://www.facebook.com/IdahoBusinessReview/" target="_blank"><i class="tieicon-facebook"></i></a><a class="tooldown" title="Twitter" href="https://twitter.com/IBRnews" target="_blank"><i class="tieicon-twitter"></i></a><a class="tooldown" title="LinkedIn" href="https://www.linkedin.com/company/idaho-business-review" target="_blank"><i class="tieicon-linkedin"></i></a><a class="tooldown" title="Vimeo" href="https://vimeo.com/channels/idahobusinessreview" target="_blank"><i class="tieicon-vimeo"></i></a><a class="tooldown" title="instagram" href="https://www.instagram.com/idahobusinessreview/" target="_blank"><i class="tieicon-instagram"></i></a><a class="tooldown" title="photo" href="http://www.idahobusinessreview.smugmug.com/" target="_blank"><i class="tieicon-photo"></i></a>	</div>

	
				<div class="top-menu"><ul id="menu-subscribe" class="menu"><li id="menu-item-110371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110371"><a href="http://idahobusinessreview.com/subscribe?source=wp_head">Subscribe</a></li>
<li id="menu-item-110373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110373"><a href="https://subscribe.idahobusinessreview.com/index.cfm?display=login">Manage Account</a></li>
<li><a href="/2017/06/05/israel-catz-joins-lee-pesky-center/?dmcss=login">LOG IN</a></li></ul></div>	
	<div class="breaking-news">
		<span>Don't Miss</span>
				
					<ul>
							<li><a href="http://idahobusinessreview.com/2017/06/05/jim-beitz-to-manage-eastern-idaho-branch-for-foodbank/" title="Jim Beitz to manage Eastern Idaho branch for Foodbank">Jim Beitz to manage Eastern Idaho branch for Foodbank</a></li>
							<li><a href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/" title="Israel Catz joins Lee Pesky Center">Israel Catz joins Lee Pesky Center</a></li>
							<li><a href="http://idahobusinessreview.com/2017/06/05/idaho-labor-department-state-population-to-near-2m-by-2025/" title="Idaho Labor Department: State population to near 2M by 2025">Idaho Labor Department: State population to near 2M by 2025</a></li>
							<li><a href="http://idahobusinessreview.com/2017/06/05/construction-leads-6217/" title="Construction Leads 6/2/17&nbsp;">Construction Leads 6/2/17&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="http://idahobusinessreview.com/2017/06/05/leads-for-the-week-of-6217/" title="Leads for the week of 6/2/17&nbsp;">Leads for the week of 6/2/17&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="http://idahobusinessreview.com/2017/06/05/court-records-6217/" title="Court Records 6/2/17&nbsp;">Court Records 6/2/17&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="http://idahobusinessreview.com/2017/06/05/independent-bookstores-are-on-the-rise/" title="Independent bookstores are on the rise&nbsp;">Independent bookstores are on the rise&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="http://idahobusinessreview.com/2017/06/05/sunroc-building-materials-opens-store-in-idaho-falls/" title="Sunroc Building Materials opens store in Idaho Falls&nbsp;">Sunroc Building Materials opens store in Idaho Falls&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="http://idahobusinessreview.com/2017/06/05/multifamily-housing-more-choices-lead-to-stronger-communities/" title="Multifamily housing: More choices lead to stronger communities">Multifamily housing: More choices lead to stronger communities</a></li>
							<li><a href="http://idahobusinessreview.com/2017/06/05/my-place-opens-in-meridian-now-eyes-downtown-boise-and-rest-of-idaho/" title="My Place hotels eyes downtown Boise and rest of Idaho&nbsp;">My Place hotels eyes downtown Boise and rest of Idaho&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
						</ul>
					
						<script type="text/javascript">
			jQuery(document).ready(function(){
								jQuery('.breaking-news ul').innerfade({animationtype: 'fade', speed: 750 , timeout: 3500});
							});
		</script>
	</div> <!-- .breaking-news -->				
								<div class="top-menu-liney" style="display:none;">
					<a class="top-menu-footer-liney"  href="javascript:;" onclick="toggleMobileMenu();" >
											</a>
				</div>
								
				
			</div>
		</div><!-- .top-menu /-->
		
		<div class="container">
		<header id="theme-header">
		<div class="header-content fade-in animated1">
			<div class="logo" style="margin-top:15px">
			<h2>
																<a title="Idaho Business Review" href="http://idahobusinessreview.com/">
					<img onerror="this.src='/files/2014/03/ibrlogo.png';this.onerror=null;" src="/files/2014/03/ibrlogo.svg" alt="Idaho Business Review" /><strong>Idaho Business Review IBR</strong>
				</a>
			</h2>			</div><!-- .logo /-->
				<div class="overlay" id="mobilemenu" >
			<div class="mobile-menu-container">
		<div class="mobile_menu"><ul id="mobile_menu" class="menu"><li id="menu-item-109531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-109531"><a href="http://idahobusinessreview.com/">Home</a></li>
<li id="menu-item-109521" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-109521"><a href="http://idahobusinessreview.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-110165" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110165"><a href="http://idahobusinessreview.com/category/news/business-news/">Business News</a></li>
	<li id="menu-item-129934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129934"><a href="http://idahobusinessreview.com/category/news/construction/">Construction News</a></li>
	<li id="menu-item-129935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-129935"><a href="http://idahobusinessreview.com/category/news/real-estate/">Real Estate News</a>
	<ul class="sub-menu">
		<li id="menu-item-176103" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-176103"><a href="http://idahobusinessreview.com/category/news/roundup/">Roundup</a></li>
	</ul>
</li>
	<li id="menu-item-110166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110166"><a href="http://idahobusinessreview.com/category/commentary/">Commentary</a></li>
	<li id="menu-item-193349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-193349"><a href="http://idahobusinessreview.com/outlook/">Idaho Outlook Indicator</a></li>
	<li id="menu-item-188907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-188907"><a href="http://idahobusinessreview.com/news-specials/">Newsroom Events &#038; Pubs</a>
	<ul class="sub-menu">
		<li id="menu-item-109537" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109537"><a href="http://idahobusinessreview.com/specpubs__trashed/breakfast-series/">IBR Breakfast Series</a></li>
		<li id="menu-item-151130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151130"><a href="http://idahobusinessreview.com/square-feet/">Square Feet</a></li>
		<li id="menu-item-187867" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-187867"><a href="http://idahobusinessreview.com/specpubs__trashed/workforce/">Workforce</a></li>
		<li id="menu-item-188896" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188896"><a href="http://idahobusinessreview.com/category/its-your-business/">It&#8217;s Your Business</a></li>
		<li id="menu-item-161737" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161737"><a href="http://idahobusinessreview.com/specpubs__trashed/downtown-boise-renewal-3/">Downtown Boise Renewal</a></li>
		<li id="menu-item-188909" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188909"><a href="http://idahobusinessreview.com/category/drive-time/">Drive Time</a></li>
	</ul>
</li>
	<li id="menu-item-140308" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-140308"><a href="http://idahobusinessreview.com/digital-edition/">Digital Edition&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
</ul>
</li>
<li id="menu-item-194705" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-194705"><a href="http://idahobusinessreview.com/ibr-awards-events-publications/">Awards Events &#038; Pubs</a>
<ul class="sub-menu">
	<li id="menu-item-109543" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109543"><a href="http://idahobusinessreview.com/events/woy/">Women of the Year</a></li>
	<li id="menu-item-109535" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109535"><a href="http://idahobusinessreview.com/events/ceo/">CEO of Influence</a></li>
	<li id="menu-item-109533" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109533"><a href="http://idahobusinessreview.com/events/au40/">Accomplished Under 40</a></li>
	<li id="menu-item-109541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109541"><a href="http://idahobusinessreview.com/events/excellence-in-finance/">Excellence in Finance</a></li>
	<li id="menu-item-109542" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109542"><a href="http://idahobusinessreview.com/events/tp/">Top Projects</a></li>
	<li id="menu-item-110318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110318"><a href="http://idahobusinessreview.com/events/leaders-in-law/">Leaders in Law</a></li>
	<li id="menu-item-194713" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-194713"><a href="http://idahobusinessreview.com/events/award-nomination-forms/">Nomination Forms</a></li>
	<li id="menu-item-160013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-160013"><a href="http://idahobusinessreview.com/2016-award-applications/">Awards applications</a></li>
	<li id="menu-item-130416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130416"><a href="http://www.idahobusinessreview.smugmug.com">Event Photos</a></li>
</ul>
</li>
<li id="menu-item-130036" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-130036"><a href="http://idahobusinessreview.com/ibr-special-publications/">Other Publications</a>
<ul class="sub-menu">
	<li id="menu-item-109538" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109538"><a href="http://idahobusinessreview.com/specpubs__trashed/bol/">Book of Lists</a></li>
	<li id="menu-item-190455" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-190455"><a href="http://idahobusinessreview.com/reader-rankings/">IBR Reader Rankings</a></li>
	<li id="menu-item-109536" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109536"><a href="http://idahobusinessreview.com/guide/">The Complete Planners&#8217; Guide for All Corporate Events</a></li>
	<li id="menu-item-109540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109540"><a href="http://idahobusinessreview.com/specpubs__trashed/state-of-downtown-boise/">State of Downtown Boise</a></li>
	<li id="menu-item-110317" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110317"><a href="http://idahobusinessreview.com/specpubs__trashed/ccim-directory/">CCIM Directory</a></li>
	<li id="menu-item-110312" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110312"><a href="http://idahobusinessreview.com/specpubs__trashed/welcome-to-boise/">Welcome to Boise</a></li>
	<li id="menu-item-110313" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110313"><a href="http://idahobusinessreview.com/specpubs__trashed/travelog/">Travelog</a></li>
	<li id="menu-item-110315" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110315"><a href="http://idahobusinessreview.com/specpubs__trashed/heartland-living/">Idaho Heartland Living</a></li>
	<li id="menu-item-161751" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161751"><a href="http://idahobusinessreview.com/specpubs__trashed/mccall-map/">McCall Map</a></li>
</ul>
</li>
<li id="menu-item-111134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111134"><a href="http://idahobusinessreview.com/book-of-lists4">TopLists</a></li>
<li id="menu-item-109527" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109527"><a href="http://idahobusinessreview.com/about/advertising/">Advertising</a></li>
<li id="menu-item-131281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-131281"><a href="http://idahobusinessreview.com/leads-from-public-records/">Public Notice &#038; Leads</a>
<ul class="sub-menu">
	<li id="menu-item-110984" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110984"><a href="http://publicnotices.idahobusinessreview.com">Public Notice</a></li>
	<li id="menu-item-130436" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-130436"><a href="http://idahobusinessreview.com/leads-from-public-records-xlsx/">Leads from public records</a>
	<ul class="sub-menu">
		<li id="menu-item-191754" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191754"><a href="http://idahobusinessreview.com/using-leads/">How to use Idaho Business Review LEADS from public records</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-193746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193746"><a href="http://idahobusinessreview.com/category/outlook-indicator/">Idaho Outlook Indicator</a></li>
</ul></div>	
	<div class="mobile_footer_menu"><ul id="mobile_footer_menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110371"><a href="http://idahobusinessreview.com/subscribe?source=wp_head">Subscribe</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110373"><a href="https://subscribe.idahobusinessreview.com/index.cfm?display=login">Manage Account</a></li>
</ul></div>	<div id="mobile-menu-footer-close-container">
		<a href="javascript:;" id="mobile-menu-footer-close" onclick="toggleMobileMenu();"></a>
	</div>
</div> <!-- .mobile-menu-container -->		</div>
					<div class="e3lan-top">					<div class="openx shortcode" id="top-ad-inner"><img class="close-ad-image" src="/wp-content/themes/jarida/images/solid-close-square.png" />

<!--/* OpenX Javascript Tag v2.5.60-beta */-->

<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ad2.dolanadserver.com/ibr/www/delivery//ajs.php':'http://ad2.dolanadserver.com/ibr/www/delivery//ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=97");
   document.write ('&amp;category=People');
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ad2.dolanadserver.com/ibr/www/delivery//ck.php?n=e18975&amp;cb=c23a3c28877a132285cd704629ffdafb' target='_blank'><img src='http://ad2.dolanadserver.com/ibr/www/delivery//avw.php?zoneid=97&amp;cb=c23a3c28877a132285cd704629ffdafb&amp;n=e18975' border='0' alt='' /></a></noscript>
</div>
				</div>			<div class="clear"></div>
		</div>
									<nav id="main-nav" class="fade-in animated2 fixed-enabled">
				<div class="container">
				<div class="main-menu"><ul id="menu-news" class="menu"><li id="menu-item-109531" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-home"><a href="http://idahobusinessreview.com/">Home</a></li>
<li id="menu-item-109521" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://idahobusinessreview.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-110165" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/news/business-news/">Business News</a></li>
	<li id="menu-item-129934" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/news/construction/">Construction News</a></li>
	<li id="menu-item-129935" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://idahobusinessreview.com/category/news/real-estate/">Real Estate News</a>
	<ul class="sub-menu">
		<li id="menu-item-176103" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/news/roundup/">Roundup</a></li>
	</ul> <!--End Sub Menu -->
</li>
	<li id="menu-item-110166" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/commentary/">Commentary</a></li>
	<li id="menu-item-193349" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/outlook/">Idaho Outlook Indicator</a></li>
	<li id="menu-item-188907" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="http://idahobusinessreview.com/news-specials/">Newsroom Events &#038; Pubs</a>
	<ul class="sub-menu">
		<li id="menu-item-109537" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/breakfast-series/">IBR Breakfast Series</a></li>
		<li id="menu-item-151130" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.com/square-feet/">Square Feet</a></li>
		<li id="menu-item-187867" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/workforce/">Workforce</a></li>
		<li id="menu-item-188896" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/its-your-business/">It&#8217;s Your Business</a></li>
		<li id="menu-item-161737" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/downtown-boise-renewal-3/">Downtown Boise Renewal</a></li>
		<li id="menu-item-188909" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/drive-time/">Drive Time</a></li>
	</ul> <!--End Sub Menu -->
</li>
	<li id="menu-item-140308" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/digital-edition/">Digital Edition&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-194705" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="http://idahobusinessreview.com/ibr-awards-events-publications/">Awards Events &#038; Pubs</a>
<ul class="sub-menu">
	<li id="menu-item-109543" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/woy/">Women of the Year</a></li>
	<li id="menu-item-109535" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/ceo/">CEO of Influence</a></li>
	<li id="menu-item-109533" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/au40/">Accomplished Under 40</a></li>
	<li id="menu-item-109541" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/excellence-in-finance/">Excellence in Finance</a></li>
	<li id="menu-item-109542" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/tp/">Top Projects</a></li>
	<li id="menu-item-110318" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/events/leaders-in-law/">Leaders in Law</a></li>
	<li id="menu-item-194713" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.com/events/award-nomination-forms/">Nomination Forms</a></li>
	<li id="menu-item-160013" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.com/2016-award-applications/">Awards applications</a></li>
	<li id="menu-item-130416" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://www.idahobusinessreview.smugmug.com">Event Photos</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-130036" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="http://idahobusinessreview.com/ibr-special-publications/">Other Publications</a>
<ul class="sub-menu">
	<li id="menu-item-109538" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/bol/">Book of Lists</a></li>
	<li id="menu-item-190455" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/reader-rankings/">IBR Reader Rankings</a></li>
	<li id="menu-item-109536" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/guide/">The Complete Planners&#8217; Guide for All Corporate Events</a></li>
	<li id="menu-item-109540" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/state-of-downtown-boise/">State of Downtown Boise</a></li>
	<li id="menu-item-110317" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/ccim-directory/">CCIM Directory</a></li>
	<li id="menu-item-110312" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/welcome-to-boise/">Welcome to Boise</a></li>
	<li id="menu-item-110313" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/travelog/">Travelog</a></li>
	<li id="menu-item-110315" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/heartland-living/">Idaho Heartland Living</a></li>
	<li id="menu-item-161751" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/specpubs__trashed/mccall-map/">McCall Map</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-111134" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.com/book-of-lists4">TopLists</a></li>
<li id="menu-item-109527" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/about/advertising/">Advertising</a></li>
<li id="menu-item-131281" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="http://idahobusinessreview.com/leads-from-public-records/">Public Notice &#038; Leads</a>
<ul class="sub-menu">
	<li id="menu-item-110984" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://publicnotices.idahobusinessreview.com">Public Notice</a></li>
	<li id="menu-item-130436" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="http://idahobusinessreview.com/leads-from-public-records-xlsx/">Leads from public records</a>
	<ul class="sub-menu">
		<li id="menu-item-191754" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://idahobusinessreview.com/using-leads/">How to use Idaho Business Review LEADS from public records</a></li>
	</ul> <!--End Sub Menu -->
</li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-193746" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://idahobusinessreview.com/category/outlook-indicator/">Idaho Outlook Indicator</a></li>
</ul></div>				</div>
			</nav><!-- .main-nav /-->
		</header><!-- #header /-->

	<div id="main-content" class="container fade-in animated3">
		<div id="content-background-cover" class="mobile-menu-background-cover"></div><div class="content-wrap">
	<div class="content">
        <div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="http://idahobusinessreview.com"><i class="tieicon-home"></i>Home</a></span> / <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="http://idahobusinessreview.com/category/people/">People</a></span> / <span class="current">Israel Catz joins Lee Pesky Center</span></div>		
		
				
						
		<article id="the-post" class="post-listing hnews hentry item post-196718 post type-post status-publish format-standard has-post-thumbnail category-people always_free">
				

			<div class="post-inner">
             				<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">Israel Catz joins Lee Pesky Center</span></h1>
                             
						
<p class="post-meta">
		
	<span class="post-meta-author">By:  <a href="http://idahobusinessreview.com/author/ibrstaff/" title="">IBR Staff </a></span>
    	
		
	 <span class="tie-date">June 5, 2017</span>	
	<span class="post-comments"><a href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/#respond">0</a></span>
</p>
<div class="clear"></div>
	
				<div class="entry entry-content">
					
					<div class="page" title="Page 1">
<div class="layoutArea">
<div class="column">
<div id="attachment_196722" style="width: 185px" class="wp-caption alignleft"><a href="http://idahobusinessreview.com/files/2017/06/Israel-Catz.jpg"><img class="size-thumbnail wp-image-196722" src="http://idahobusinessreview.com/files/2017/06/Israel-Catz-175x117.jpg" alt="Israel Catz" width="175" height="117" srcset="http://idahobusinessreview.com/files/2017/06/Israel-Catz-175x117.jpg 175w, http://idahobusinessreview.com/files/2017/06/Israel-Catz-300x201.jpg 300w, http://idahobusinessreview.com/files/2017/06/Israel-Catz-600x400.jpg 600w, http://idahobusinessreview.com/files/2017/06/Israel-Catz-180x120.jpg 180w, http://idahobusinessreview.com/files/2017/06/Israel-Catz-468x312.jpg 468w, http://idahobusinessreview.com/files/2017/06/Israel-Catz.jpg 640w" sizes="(max-width: 175px) 100vw, 175px" /></a><p class="wp-caption-text">Israel Catz</p></div>
<p>Israel Catz has been named the next executive director of the Lee Pesky Learning Center in Boise.</p></div>
<div class="column"></div>
<div class="column">The existing executive director, Evelyn Johnson, has assumed the newly created role of scientific director at the Boise nonprofit.<br />
Catz, who assumes the executive director&#8217;s role July 10,  is a graduate of the Harvard Graduate School of Education and Middlebury College. His previous experience includes teaching at Riverstone International School in Boise and as a Peace Corps Volunteer in Madagascar, where he founded Antanosy Aid Association to combat hunger and illiteracy. He will oversee the center’s core services of evaluation, intervention, professional development, operations, and fundraising, and will work in partnership with Johnson to implement research-based initiatives.</p>
<p>The LPLC provides evidence-based learning intervention models and research in the field of learning disabilities.</p></div>
</div>
</div>
<div class="page" title="Page 2">
<div class="layoutArea">
<div class="column"></div>
</div>
</div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-196718" class="share-facebook sd-button share-icon" href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-196718" class="share-linkedin sd-button share-icon" href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-196718" class="share-twitter sd-button share-icon" href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-196718" class="share-google-plus-1 sd-button share-icon" href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-end"></li></ul></div></div></div>										
					
									</div><!-- .entry /-->
				                <span style="display:none" class="updated" title="2017-06-05T15:25:50Z">3:25 pm Mon, June 5, 2017</span>
                <span class="source-org vcard" style="display:none;"><a class="org fn" href="http://idahobusinessreview.com">Idaho Business Review</a></span>								<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="http://idahobusinessreview.com/author/ibrstaff/" title="Posts by IBR Staff" rel="author">IBR Staff</a></strong></div>
								
								
			</div><!-- .post-inner -->
		</article><!-- .post-listing -->
		        
		
				
						
		<div class="post-navigation">
			<div class="post-previous"><a href="http://idahobusinessreview.com/2017/06/05/idaho-labor-department-state-population-to-near-2m-by-2025/" rel="prev"><span>Previous:</span> Idaho Labor Department: State population to near 2M by 2025</a></div>
			<div class="post-next"><a href="http://idahobusinessreview.com/2017/06/05/jim-beitz-to-manage-eastern-idaho-branch-for-foodbank/" rel="next"><span>Next:</span> Jim Beitz to manage Eastern Idaho branch for Foodbank</a></div>
		</div><!-- .post-navigation -->
				
				
		<section id="author-box">
			<div class="block-head">
				<h3>About IBR Staff </h3>
			</div>
			<div class="post-listing">
						<div class="author-avatar">
			<img alt='' src='http://0.gravatar.com/avatar/0633638b408ca148b5deceab7d864a53?s=60&#038;r=pg' srcset='http://0.gravatar.com/avatar/0633638b408ca148b5deceab7d864a53?s=120&amp;r=pg 2x' class='avatar avatar-60 photo' height='60' width='60' />		</div><!-- #author-avatar -->
		<div class="author-description">
			</div><!-- #author-description -->
			<div class="author-social">
							<a class="ttip" href="http://" title="IBR Staff 's site"><img src="http://idahobusinessreview.com/wp-content/themes/jarida/images/author_site.png" width="18" height="18" alt="" /></a>
																																</div>
		<div class="clear"></div>
				</div>
		</section><!-- #author-box -->
		
			

		
                		<div id="comments">



				<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/06/05/israel-catz-joins-lee-pesky-center/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://idahobusinessreview.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<p class="comment-notes">Your email address will not be published. Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <span class="required">*</span><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email</label> <span class="required">*</span><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='196718' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1aefa29661" /></p><div class="g-recaptcha" data-sitekey="6Le2xiMTAAAAAFD40x_ZtsDlPGwfRMUy7mVRR2Ki" data-theme="standard"></div><script type="text/javascript"src="https://www.google.com/recaptcha/api.js?hl=en"></script>            <div id="recaptcha-submit-btn-area">&nbsp;</div>
            <noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="94"/></p>				</form>
					</div><!-- #respond -->
		
</div><!-- #comments -->
        	
	</div><!-- .content -->
<aside class="sidebar-narrow">
			<div id="text-html-widget-13" class="text-html-box" >
			<p><strong>Sign up for the Idaho Business Review email alerts FREE!</strong></p><br>

<style>

.ao_tbl_cell{padding-left: 0px !important; padding-bottom:10px !important;}

.form_0028_ao_submit_button{float:left;}

</style>

<!-- ======================================================================================= -->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<link rel="stylesheet" type="text/css" href="//news.thedolancompany.com/acton/formNegCap.css">
<script type="text/javascript" src="//news.thedolancompany.com/acton/form/20728/0028/form.js">
</script>
<!-- ======================================================================================= -->
<!-- place exactly one copy of everything above these lines in the head section of your page -->
<!-- place everything below these lines in the body section of your page -->
<!-- ======================================================================================= -->
<form id="form_0028" method="post" enctype="multipart/form-data" action="//news.thedolancompany.com/acton/forms/userSubmit.jsp" accept-charset="UTF-8" target="_self">
<input type="hidden" name="ao_a" value="20728" >
<input type="hidden" name="ao_f" value="0028" >
<input type="hidden" name="ao_d" value="0028:d-0001" >
<input type="hidden" name="ao_p" id="ao_p" value="0" >
<input type="hidden" name="ao_jstzo" id="ao_jstzo" value="" >
<input type="hidden" name="ao_cuid" value="" >
<input type="hidden" name="ao_srcid" value="" >
<input type="hidden" name="ao_bot" id="ao_bot" value="yes" >
<input type="hidden" name="ao_camp" value="" >
<link rel="stylesheet" type="text/css" href="//news.thedolancompany.com/acton/form/20728/0028/form.css">
<div id="ao_alignment_container" class="aoFormContainer" align="center">
<table class="ao_tbl_container" border="0" cellspacing="0" cellpadding="0" style="margin-top:-10px;">
<tr>
<td class="ao_tbl_cell" style="padding-left: 10px; " align="center">
<div align="left">
<div class="formField">
<div class="formFieldLabel" id="form_0028_fld_0-Label">
<label for = "form_0028_fld_0">
Email Address</label>
<b style="color: #FF0000; cursor: default" title="Required Field">
*</b>
</div>
<input type="text" class="formFieldText formFieldMedium" id="form_0028_fld_0" name="email" onBlur="singleCheck ('form_0028_fld_0', 'EMAIL', 'form_0028_fld_0-Label')">
</div>
<script type="text/javascript">
if (typeof(addRequiredField) != 'undefined') { addRequiredField ('form_0028_fld_0'); } </script>
<script type="text/javascript">
if (typeof(addFieldToValidate) != 'undefined') { addFieldToValidate ('form_0028_fld_0', 'EMAIL'); } </script>
</div>
</td>
</tr>
<tr>
<td class="ao_tbl_cell" style="padding-left: 10px; padding-right: 10px" align="center">
<div align="left">
<input type="hidden" id="form_0028_fld_1" name="IBR Daily Alert" value="yes">
</div>
</td>
</tr>
<tr>
<td class="ao_tbl_cell" style="padding-left: 10px; padding-right: 10px" align="center">
<div align="left">
<input type="hidden" id="form_0028_fld_2" name="Source" value="website">
</div>
</td>
</tr>
<tr>
<td class="ao_tbl_cell" style="padding-left: 10px; padding-right: 10px" align="center">
<div align="left">
<input type="hidden" id="form_0028_fld_3" name="IBR CircMktg Alert" value="yes">
</div>
</td>
</tr>
<input type="hidden" id="form_0028_fld_4" name="Special Offers from Select Partners" value="true">
<!-- BUTTONS -->
<tr>
<td style="margin-top:-30px;" align="center" id="form_0028_ao_submit_button">
<a id="form_0028_ao_submit_href" href="javascript: doSubmit(document.getElementById('form_0028'))">
<img src="http://news.thedolancompany.com/cdnr/46/acton/attachment/20728/f-0090/1/-/-/-/-/image.png" border="0">
</a>
</td>
</tr>
<tr class="formNegCap">
<td>
<input type="text" id="ao_form_neg_cap" name="ao_form_neg_cap" value="">
</td>
</tr>
</table>
</div>
<img src='//news.thedolancompany.com/acton/form/20728/0028:d-0001/pgend.gif' width='1' height='1'>
</form>			</div>
		<div id="categort-posts-widget-8" class="widget categort-posts"><div class="widget-top"><h4><a href="http://idahobusinessreview.com/category/people/">People</a>		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li >
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2017/06/05/jim-beitz-to-manage-eastern-idaho-branch-for-foodbank/" title="Permalink to Jim Beitz to manage Eastern Idaho branch for Foodbank" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2017/06/jim-beitz-70x70.png" class="attachment-tie-small size-tie-small wp-post-image" alt="jim-beitz" srcset="http://idahobusinessreview.com/files/2017/06/jim-beitz-70x70.png 70w, http://idahobusinessreview.com/files/2017/06/jim-beitz-100x100.png 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2017/06/05/jim-beitz-to-manage-eastern-idaho-branch-for-foodbank/">Jim Beitz to manage Eastern Idaho branch for Foodbank</a></h3>
			 <span class="date"><span class="tie-date">June 5, 2017</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/" title="Permalink to Israel Catz joins Lee Pesky Center" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2017/06/Israel-Catz-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Israel Catz" srcset="http://idahobusinessreview.com/files/2017/06/Israel-Catz-70x70.jpg 70w, http://idahobusinessreview.com/files/2017/06/Israel-Catz-200x200.jpg 200w, http://idahobusinessreview.com/files/2017/06/Israel-Catz-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/">Israel Catz joins Lee Pesky Center</a></h3>
			 <span class="date"><span class="tie-date">June 5, 2017</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2017/06/02/joy-fisher-is-promoted-to-director-of-university-of-idaho-foundation/" title="Permalink to Joy Fisher is promoted to director of University of Idaho Foundation" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2017/06/Joy-Fisher-1-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="joy-fisher" srcset="http://idahobusinessreview.com/files/2017/06/Joy-Fisher-1-70x70.jpg 70w, http://idahobusinessreview.com/files/2017/06/Joy-Fisher-1-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2017/06/02/joy-fisher-is-promoted-to-director-of-university-of-idaho-foundation/">Joy Fisher is promoted to director of University of Idaho Foundation</a></h3>
			 <span class="date"><span class="tie-date">June 2, 2017</span></span>
		</li>
			<li >
						<h3><a href="http://idahobusinessreview.com/2017/06/02/john-blake-promoted-to-deputy-chief-at-ada-county-paramedics/">John Blake promoted to deputy chief at Ada County Paramedics</a></h3>
			 <span class="date"><span class="tie-date">June 2, 2017</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2017/06/02/amie-longmore-joins-create-common-good-as-community-impact-and-training-manager/" title="Permalink to Amie Longmire joins Create Common Good as community impact and training manager" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2017/05/Amie-Longmire-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="amie-longmire" srcset="http://idahobusinessreview.com/files/2017/05/Amie-Longmire-70x70.jpg 70w, http://idahobusinessreview.com/files/2017/05/Amie-Longmire-200x200.jpg 200w, http://idahobusinessreview.com/files/2017/05/Amie-Longmire-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2017/06/02/amie-longmore-joins-create-common-good-as-community-impact-and-training-manager/">Amie Longmire joins Create Common Good as community impact and training manager</a></h3>
			 <span class="date"><span class="tie-date">June 2, 2017</span></span>
		</li>
		
				</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /--><div id="categort-posts-widget-9" class="widget categort-posts"><div class="widget-top"><h4><a href="http://idahobusinessreview.com/category/top-stories/">Top Stories</a>		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li >
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2017/06/05/idaho-labor-department-state-population-to-near-2m-by-2025/" title="Permalink to Idaho Labor Department: State population to near 2M by 2025" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2016/04/1.-traffic-downtown1-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Traffic in downtown Boise, April 2016, Photo Patrick Sweeney" srcset="http://idahobusinessreview.com/files/2016/04/1.-traffic-downtown1-70x70.jpg 70w, http://idahobusinessreview.com/files/2016/04/1.-traffic-downtown1-200x200.jpg 200w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2017/06/05/idaho-labor-department-state-population-to-near-2m-by-2025/">Idaho Labor Department: State population to near 2M by 2025</a></h3>
			 <span class="date"><span class="tie-date">June 5, 2017</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2017/06/05/independent-bookstores-are-on-the-rise/" title="Permalink to Independent bookstores are on the rise&nbsp;" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2017/05/Rediscovered-Books-cropped-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Rediscovered Books" srcset="http://idahobusinessreview.com/files/2017/05/Rediscovered-Books-cropped-70x70.jpg 70w, http://idahobusinessreview.com/files/2017/05/Rediscovered-Books-cropped-200x200.jpg 200w, http://idahobusinessreview.com/files/2017/05/Rediscovered-Books-cropped-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2017/06/05/independent-bookstores-are-on-the-rise/">Independent bookstores are on the rise&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">June 5, 2017</span></span>
		</li>
			<li >
						<h3><a href="http://idahobusinessreview.com/2017/06/05/sunroc-building-materials-opens-store-in-idaho-falls/">Sunroc Building Materials opens store in Idaho Falls&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">June 5, 2017</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2017/06/05/my-place-opens-in-meridian-now-eyes-downtown-boise-and-rest-of-idaho/" title="Permalink to My Place hotels eyes downtown Boise and rest of Idaho&nbsp;" rel="bookmark"><img width="70" height="70" src="http://idahobusinessreview.com/files/2017/06/my-place-meridian-web-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="The first My Place hotel in Idaho opened in April in Meridian at Eagle Road and Fairview Ave. Photo by Teya Vitu." srcset="http://idahobusinessreview.com/files/2017/06/my-place-meridian-web-70x70.jpg 70w, http://idahobusinessreview.com/files/2017/06/my-place-meridian-web-200x200.jpg 200w, http://idahobusinessreview.com/files/2017/06/my-place-meridian-web-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2017/06/05/my-place-opens-in-meridian-now-eyes-downtown-boise-and-rest-of-idaho/">My Place hotels eyes downtown Boise and rest of Idaho&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">June 5, 2017</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="http://idahobusinessreview.com/2017/06/03/farmers-decry-trump-plans-to-cut-agriculture-subsidies/" title="Permalink to Farmers decry Trump plans to cut agriculture subsidies" rel="bookmark"><img width="70" height="47" src="http://idahobusinessreview.com/files/2012/03/corn-IF-web-032312.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="File photo courtesy Idaho Farm Bureau Federation" srcset="http://idahobusinessreview.com/files/2012/03/corn-IF-web-032312.jpg 573w, http://idahobusinessreview.com/files/2012/03/corn-IF-web-032312-110x73.jpg 110w, http://idahobusinessreview.com/files/2012/03/corn-IF-web-032312-300x201.jpg 300w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://idahobusinessreview.com/2017/06/03/farmers-decry-trump-plans-to-cut-agriculture-subsidies/">Farmers decry Trump plans to cut agriculture subsidies</a></h3>
			 <span class="date"><span class="tie-date">June 3, 2017</span></span>
		</li>
		
				</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /--><div id="dmc-post-feed-10" class="widget widget_dmc-post-feed"><div class="widget-container"><div class="widget-top"><h4> </h4></div>
<div><span style="font-size: x-small;">Our best, right now.</span><ul><li><a href="http://idahobusinessreview.com/2017/05/05/supporting-the-workforce-the-evolving-role-of-the-human-resource-professional/?ep=1"><strong style="font-size: x-small;">Supporting the Workforce: The evolving role of the human resource professional</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Dani Grigg |</span> <span style="font-size: xx-small; color: #cccccc;">May. 5</span></li><li><a href="http://idahobusinessreview.com/2017/03/01/tastemakers-restaurants-breweries/?ep=1"><strong style="font-size: x-small;">Tastemakers: Restaurants & breweries</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Dani Grigg |</span> <span style="font-size: xx-small; color: #cccccc;">Mar. 1</span></li><li><a href="http://idahobusinessreview.com/2016/12/30/forum-on-the-future-ibr-breakfast-series-report/?ep=1"><strong style="font-size: x-small;">Forum on the Future: IBR Breakfast Series report</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Dani Grigg |</span> <span style="font-size: xx-small; color: #cccccc;">Dec. 30</span></li><li><a href="http://idahobusinessreview.com/2016/11/04/low-key-high-tech-ibr-breakfast-series-report/?ep=1"><strong style="font-size: x-small;">Low key & high tech: IBR Breakfast Series report</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Dani Grigg |</span> <span style="font-size: xx-small; color: #cccccc;">Nov. 4</span></li><li><a href="http://idahobusinessreview.com/2016/10/11/largest-valley-country-store-is-under-construction-in-jerome/?ep=1"><strong style="font-size: x-small;">Largest Valley Country Store is under construction in Jerome</strong></a><br><span style="font-size: xx-small; color: #aaaaaa;">by Teya Vitu |</span> <span style="font-size: xx-small; color: #cccccc;">Oct. 11</span></li></ul> </div></div></div><!-- .widget /--></aside>
</div> <!-- .content-wrap -->
<aside class="sidebar">
<div id="social-9" class="widget social-icons-widget"><div class="widget-top"><h4>Follow IBR</h4><div class="stripe-line"></div></div>
						<div class="widget-container">	<div class="social-icons icon_32">
		<a class="ttip" title="Rss" href="http://idahobusinessreview.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="ttip" title="Facebook" href="https://www.facebook.com/IdahoBusinessReview/" target="_blank"><i class="tieicon-facebook"></i></a><a class="ttip" title="Twitter" href="https://twitter.com/IBRnews" target="_blank"><i class="tieicon-twitter"></i></a><a class="ttip" title="LinkedIn" href="https://www.linkedin.com/company/idaho-business-review" target="_blank"><i class="tieicon-linkedin"></i></a><a class="ttip" title="Vimeo" href="https://vimeo.com/channels/idahobusinessreview" target="_blank"><i class="tieicon-vimeo"></i></a><a class="ttip" title="instagram" href="https://www.instagram.com/idahobusinessreview/" target="_blank"><i class="tieicon-instagram"></i></a><a class="ttip" title="photo" href="http://www.idahobusinessreview.smugmug.com/" target="_blank"><i class="tieicon-photo"></i></a>	</div>

	</div></div><!-- .widget /--><div id="dmc_openx-1082297721" class="widget widget_dmc_openx"><div id="open-x" align="left" style="padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;"><div class="widget-container">

<!--/* OpenX Javascript Tag v2.5.60-beta */-->

<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ad2.dolanadserver.com/ibr/www/delivery//ajs.php':'http://ad2.dolanadserver.com/ibr/www/delivery//ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=155");
   document.write ('&amp;category=People');
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ad2.dolanadserver.com/ibr/www/delivery//ck.php?n=c656f8&amp;cb=ffacff461fc9bacc539ad62e19b9695c' target='_blank'><img src='http://ad2.dolanadserver.com/ibr/www/delivery//avw.php?zoneid=155&amp;cb=ffacff461fc9bacc539ad62e19b9695c&amp;n=c656f8' border='0' alt='' /></a></noscript>
</div></div></div><!-- .widget /--><div id="dmc_openx-873298766" class="widget widget_dmc_openx"><div id="open-x" align="left" style="padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;"><div class="widget-container">

<!--/* OpenX Javascript Tag v2.5.60-beta */-->

<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ad2.dolanadserver.com/ibr/www/delivery//ajs.php':'http://ad2.dolanadserver.com/ibr/www/delivery//ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=148");
   document.write ('&amp;category=People');
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ad2.dolanadserver.com/ibr/www/delivery//ck.php?n=633227&amp;cb=ae800d9c6c52244084f87a9c4e85cbb6' target='_blank'><img src='http://ad2.dolanadserver.com/ibr/www/delivery//avw.php?zoneid=148&amp;cb=ae800d9c6c52244084f87a9c4e85cbb6&amp;n=633227' border='0' alt='' /></a></noscript>
</div></div></div><!-- .widget /--><div id="dmc-post-feed-3" class="widget widget_dmc-post-feed"><div class="widget-container"><div class="digital-edition">
<div class="widget-top ">
<h4><a href="/digital-edition/"><a href="http://idahobusinessreview.com/category/digital-edition/">Digital Edition</a></a></h4>
</div><a href="/digital-edition/"><img width="150" height="232" src="http://idahobusinessreview.com/files/2017/06/thumb_131408043631351680_IBR060217web00001.jpg" class="attachment-medium size-medium wp-post-image" alt="thumb_131408043631351680_ibr060217web00001" srcset="http://idahobusinessreview.com/files/2017/06/thumb_131408043631351680_IBR060217web00001.jpg 150w, http://idahobusinessreview.com/files/2017/06/thumb_131408043631351680_IBR060217web00001-113x175.jpg 113w" sizes="(max-width: 150px) 100vw, 150px" /></a>
<p>The Digital Edition of Idaho Business News is available to both print and online subscribers.</p>
<p><a href="/digital-edition/"><strong>Current edition</strong></a></p></div></div></div><!-- .widget /--><div id="facebook-widget-2" class="widget facebook-widget"><div class="widget-top"><h4>Find us on Facebook		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="facebook-box">
				<iframe src="http://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/IdahoBusinessReview&amp;width=300&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->		<style>

.sidebar-narrow .ao_tbl_cell{
padding-left:0px !Important;
padding-bottom:2px;
}
.sidebar-narrow #form_0028_ao_submit_button{float:left;}

</style>		</aside>
<div class="clear"></div>		<div class="clear"></div>
	</div><!-- .container /-->

		</div><!-- .container -->

	<footer class="fade-in animated4">
	<div id="footer-widget-area" class="footer-3c container">

			<div id="footer-first" class="footer-widgets-box">
			<div id="text-html-widget-2" class="footer-widget text-html"><div class="footer-widget-top"><h4>My Account</h4></div>
						<div class="footer-widget-container"><div ><ul id="footer-top-menu-liney">

<li>
<a href="/2017/06/05/israel-catz-joins-lee-pesky-center/?dmcss=login">LOG IN</a>
</li>
<li>
<a href="http://idahobusinessreview.com/subscribe?source=wp_foot">SUBSCRIBE</a>
</li>
<li>
<a href="https://subscribe.idahobusinessreview.com/index.cfm?display=login">MANAGE ACCOUNT</a>
</li>
<li>
<a href="http://bridgetowermedia.com/privacy-policy/">PRIVACY POLICY</a>
</li>
<li>
<a href="http://bridgetowermedia.com/subscriber-agreement/">SUBSCRIBER AGREEMENT</a>
</li>
</ul>
				</div><div class="clear"></div></div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
					<div id="recent-posts-nocache-2" class="footer-widget widget_recent_entries_nocache">		<div class="footer-widget-top"><h4>Recent Posts</h4></div>
						<div class="footer-widget-container">		<ul>
					<li>
				<a href="http://idahobusinessreview.com/2017/06/05/jim-beitz-to-manage-eastern-idaho-branch-for-foodbank/" title="Jim Beitz to manage Eastern Idaho branch for Foodbank">Jim Beitz to manage Eastern Idaho branch for Foodbank</a>
						</li>
					<li>
				<a href="http://idahobusinessreview.com/2017/06/05/israel-catz-joins-lee-pesky-center/" title="Israel Catz joins Lee Pesky Center">Israel Catz joins Lee Pesky Center</a>
						</li>
					<li>
				<a href="http://idahobusinessreview.com/2017/06/05/idaho-labor-department-state-population-to-near-2m-by-2025/" title="Idaho Labor Department: State population to near 2M by 2025">Idaho Labor Department: State population to near 2M by 2025</a>
						</li>
					<li>
				<a href="http://idahobusinessreview.com/2017/06/05/construction-leads-6217/" title="Construction Leads 6/2/17&nbsp;&lt;span class=&quot;dmcss_key_icon&quot;&gt;&lt;img alt=&quot;(access required)&quot; src=&quot;/files/2014/03/lock1.png&quot; border=0/&gt;&lt;/span&gt;">Construction Leads 6/2/17&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a>
						</li>
					<li>
				<a href="http://idahobusinessreview.com/2017/06/05/leads-for-the-week-of-6217/" title="Leads for the week of 6/2/17&nbsp;&lt;span class=&quot;dmcss_key_icon&quot;&gt;&lt;img alt=&quot;(access required)&quot; src=&quot;/files/2014/03/lock1.png&quot; border=0/&gt;&lt;/span&gt;">Leads for the week of 6/2/17&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a>
						</li>
				</ul>
		</div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

			<div id="footer-third" class="footer-widgets-box">
			<div id="text-html-widget-6" class="footer-widget text-html"><div class="footer-widget-top"><h4>Idaho Business Review</h4></div>
						<div class="footer-widget-container"><div ><ul>
<li>
<a href="/about/">ABOUT US</a>
</li>
<li>
<a href="/advertising/">ADVERTISING</a>
</li>
<li>
<a href="/contact-us/">CONTACT US</a>
</li>
<li>
<a href="/frequently-asked-questions/">FREQUENTLY ASKED QUESTIONS</a>
</li>
<li>
<a href="/specpubs/">OUR PUBLICATIONS</a>
</li>
<li>
<a href="/business-announcements/">SUBMIT BUSINESS ANNOUNCEMENTS</a>
</li>

</ul>
<p></p>
				</div><div class="clear"></div></div></div><!-- .widget /-->		</div><!-- #third .widget-area -->
	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
	<div class="clear"></div>
	<div class="footer-bottom fade-in animated4">
		<div class="container">
				<div class="social-icons icon_flat">
		<a class="ttip" title="Rss" href="http://idahobusinessreview.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="ttip" title="Facebook" href="https://www.facebook.com/IdahoBusinessReview/" target="_blank"><i class="tieicon-facebook"></i></a><a class="ttip" title="Twitter" href="https://twitter.com/IBRnews" target="_blank"><i class="tieicon-twitter"></i></a><a class="ttip" title="LinkedIn" href="https://www.linkedin.com/company/idaho-business-review" target="_blank"><i class="tieicon-linkedin"></i></a><a class="ttip" title="Vimeo" href="https://vimeo.com/channels/idahobusinessreview" target="_blank"><i class="tieicon-vimeo"></i></a><a class="ttip" title="instagram" href="https://www.instagram.com/idahobusinessreview/" target="_blank"><i class="tieicon-instagram"></i></a><a class="ttip" title="photo" href="http://www.idahobusinessreview.smugmug.com/" target="_blank"><i class="tieicon-photo"></i></a>	</div>

				<div class="alignleft">
			<span class="four_fifth" style="display: inline-block;text-align: center;line-height: 16px;"><span style="white-space:nowrap;">Copyright © 2017</span> <span class="vcard"><span class="fn n org" style="white-space:nowrap;">Idaho Business Review</span></span> | <span class="adr"><span class="street-address" style="white-space:nowrap;">855 W. Broad Street, Suite 103</span>, <span  style="white-space:nowrap;"><span class="locality">Boise</span>, <span class="region">ID</span> <span class="postal-code">83702</span></span></span> | <a href="tel:(208) 336-3768" style="white-space:nowrap;">Phone: (208) 336-3768</a> <a href="fax:(208) 336-5534" style="white-space:nowrap;">Fax: (208) 336-5534</a></span></span>
<span class="one_fifth_last"><a href="http://bridgetowermedia.com" style="max-width:140px;"><img alt="bridge tower media logo" src="http://bridgetowermedia.com/files/2016/08/btmlogo140.svg" onerror="this.onerror=null; this.src='http://bridgetowermedia.com/files/2016/08/btmlogo140.png'" scale="0" data-pin-nopin="true" style="max-width:140px;width:100%;"></a></span>
			</div>
		</div><!-- .Container -->
	</div><!-- .Footer bottom -->

</div><!-- .Wrapper -->
	<div id="topcontrol" class="tieicon-up-open" title="Scroll To Top"></div>
<div id="fb-root"></div>
	<div style="display:none">
	<div class="grofile-hash-map-0633638b408ca148b5deceab7d864a53">
	</div>
	</div>
<script type="text/javascript">
jQuery(".close-ad-image").click(function() {
    jQuery(this).parent().hide();
});

jQuery(document).ready(function($){
  
	$(".top-menu-footer-liney").click(function(event){
    
		event.preventDefault();
    
		var offset = $($(this).attr('href')).offset().top;
	
		offset = offset - 200;
    
		$('html, body').animate({scrollTop:offset}, 3000);
  
	});

});
</script><!-- This site is converting visitors into subscribers and customers with OptinMonster - http://optinmonster.com --><div id="om-cd4ds9hgjw2urgzy-holder"></div><script>var cd4ds9hgjw2urgzy,cd4ds9hgjw2urgzy_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){cd4ds9hgjw2urgzy_poll(function(){if(window['om_loaded']){if(!cd4ds9hgjw2urgzy){cd4ds9hgjw2urgzy=new OptinMonsterApp();return cd4ds9hgjw2urgzy.init({"u":"27526.496838","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="//a.optnmnstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;cd4ds9hgjw2urgzy=new OptinMonsterApp();cd4ds9hgjw2urgzy.init({"u":"27526.496838","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster -->
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/idahobusinessreview.com\/2017\/06\/05\/israel-catz-joins-lee-pesky-center\/":196718};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2017/06/05/israel-catz-joins-lee-pesky-center/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			
			<img style="float: right; display: none" class="loading" src="http://idahobusinessreview.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
		            <script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/mu-plugins/mkt/mkt_footer.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/idahobusinessreview.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/wp-polls/polls-js.js'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/jetpack/modules/wpgroho.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/themes/jarida/js/mobilemenu.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"go_to":"Go to...","ajaxurl":"http:\/\/idahobusinessreview.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","is_singular":"1","reading_indicator":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/themes/jarida/js/tie-scripts.js'></script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://idahobusinessreview.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201723.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.0.3',blog:'43766312',post:'196718',tz:'-6',srv:'idahobusinessreview.com'} ]);
	_stq.push([ 'clickTrackerInit', '43766312', '196718' ]);
</script>
</body>
</html>