<!DOCTYPE html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#"  xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://idahobusinessreview.com/xmlrpc.php" />
<!-- 
Server info
127.0.0.1-->
<title>Biz ‘Bite:’ Boise buys mobile home park | Idaho Business Review</title>

		<!-- All in One SEO 4.1.5.2 -->
		<meta name="description" content="In its efforts to preserve affordable housing for its residents, the City of Boise announced that it purchased the Sage Mobile Home Park in the Boise Bench neighborhood on Aug. 25. The two-acre property is near Shoshone Park with less than 200 feet walking distance to “best-in-class transit” available on Vista Avenue. The residents of ..." />
		<meta name="robots" content="max-image-preview:large" />
		<link rel="canonical" href="https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/" />
		<meta property="og:locale" content="en_US" />
		<meta property="og:site_name" content="Idaho Business Review" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Biz ‘Bite:’ Boise buys mobile home park | Idaho Business Review" />
		<meta property="og:description" content="In its efforts to preserve affordable housing for its residents, the City of Boise announced that it purchased the Sage Mobile Home Park in the Boise Bench neighborhood on Aug. 25. The two-acre property is near Shoshone Park with less than 200 feet walking distance to “best-in-class transit” available on Vista Avenue. The residents of ..." />
		<meta property="og:url" content="https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/" />
		<meta property="og:image" content="https://idahobusinessreview.com/files/2022/08/Depositphotos_244509542_XL-scaled.jpg" />
		<meta property="og:image:secure_url" content="https://idahobusinessreview.com/files/2022/08/Depositphotos_244509542_XL-scaled.jpg" />
		<meta property="og:image:width" content="2560" />
		<meta property="og:image:height" content="1705" />
		<meta property="article:published_time" content="2022-08-26T18:04:11+00:00" />
		<meta property="article:modified_time" content="2022-08-26T18:04:11+00:00" />
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:domain" content="idahobusinessreview.com" />
		<meta name="twitter:title" content="Biz ‘Bite:’ Boise buys mobile home park | Idaho Business Review" />
		<meta name="twitter:description" content="In its efforts to preserve affordable housing for its residents, the City of Boise announced that it purchased the Sage Mobile Home Park in the Boise Bench neighborhood on Aug. 25. The two-acre property is near Shoshone Park with less than 200 feet walking distance to “best-in-class transit” available on Vista Avenue. The residents of ..." />
		<meta name="twitter:image" content="https://idahobusinessreview.com/files/2022/08/Depositphotos_244509542_XL-scaled.jpg" />
		<script type="application/ld+json" class="aioseo-schema">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</script>
		<!-- All in One SEO -->


<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Idaho Business Review &raquo; Feed" href="https://idahobusinessreview.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Idaho Business Review &raquo; Comments Feed" href="https://idahobusinessreview.com/comments/feed/" />
<meta name="apple-mobile-web-app-title" content="Biz ‘Bite:’ Boise buys mobile home park | Idaho Business Review">
<link rel="apple-touch-icon" sizes="57x57" href="https://idahobusinessreview.com/files/2014/03/1br57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="https://idahobusinessreview.com/files/2014/03/1br72.png" />
<link rel="apple-touch-icon" sizes="114x114" href="https://idahobusinessreview.com/files/2014/03/1br114.png" />
<link rel="apple-touch-icon" sizes="144x144" href="https://idahobusinessreview.com/files/2014/03/1br144.png" />
<meta name='thumbnail' content='https://idahobusinessreview.com/files/2022/08/Depositphotos_244509542_XL-180x120.jpg' />
<link rel="alternate" type="application/rss+xml" title="Idaho Business Review &raquo; Biz &#8216;Bite:&#8217; Boise buys mobile home park&nbsp; Comments Feed" href="https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/feed/" />
<link rel='stylesheet' id='dashicons-css'  href='https://idahobusinessreview.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://idahobusinessreview.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://idahobusinessreview.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='cookie-law-info-css'  href='https://idahobusinessreview.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-gdpr-css'  href='https://idahobusinessreview.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css' type='text/css' media='all' />
<link rel='stylesheet' id='ssp-recent-episodes-css'  href='https://idahobusinessreview.com/wp-content/plugins/seriously-simple-podcasting/assets/css/recent-episodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='sponsored_content-css'  href='https://idahobusinessreview.com/wp-content/plugins/tdc-sponsored-content/sponsored_content.css' type='text/css' media='all' />
<link rel='stylesheet' id='solr_frontend-css'  href='https://idahobusinessreview.com/wp-content/plugins/wpsolr-pro/wpsolr/core/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpsolr-facet-range-css-css'  href='https://idahobusinessreview.com/wp-content/plugins/wpsolr-pro/wpsolr/pro/extensions/theme/template/facet-range/wpsolr-facet-range.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpsolr-facet-color-picker-css-css'  href='https://idahobusinessreview.com/wp-content/plugins/wpsolr-pro/wpsolr/pro/extensions/theme/template/facet-color-picker/wpsolr-facet-color-picker.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://idahobusinessreview.com/wp-content/themes/jarida/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='override-css-css'  href='https://idahobusinessreview.com/wp-content/themes/jarida/css/override.css?unique1661559880' type='text/css' media='all' />
<link rel='stylesheet' id='Oswald-css'  href='//fonts.googleapis.com/css?family=Oswald%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='wp-add-custom-css-css'  href='https://idahobusinessreview.com?display_custom_css=css' type='text/css' media='all' />
<link rel='stylesheet' id='dmcssStylesheet-css'  href='https://idahobusinessreview.com/wp-content/plugins/tdc-paywall-psa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='slidedeck-css'  href='https://idahobusinessreview.com/wp-content/plugins/slidedeck3-personal/css/slidedeck.css' type='text/css' media='screen' />
<script type="text/javascript">
window.slideDeck2Version = "4.5.1";
window.slideDeck2Distribution = "pro";
</script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/mu-plugins/mkt/mkt_header.js' id='mkingtbs_head-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/asentech-fifth-ads-pos//post-ads-after-fifth-script.js' id='quick-edit-script-js'></script>
<script type='text/javascript' id='cookie-law-info-js-extra'>
/* <![CDATA[ */
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[],"non_necessary_cookies":[],"ccpaEnabled":"","ccpaRegionBased":"","ccpaBarEnabled":"","strictlyEnabled":["necessary","obligatoire"],"ccpaType":"gdpr","js_blocking":"1","custom_integration":"","triggerDomRefresh":"","secure_cookies":""};
var cli_cookiebar_settings = {"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":"","button_1_button_colour":"#61a229","button_1_button_hover":"#4e8221","button_1_link_colour":"#fff","button_1_as_button":"1","button_1_new_win":"","button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":"","button_2_hidebar":"","button_3_button_colour":"#3566bb","button_3_button_hover":"#2a5296","button_3_link_colour":"#fff","button_3_as_button":"1","button_3_new_win":"","button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#333333","button_4_as_button":"","button_7_button_colour":"#61a229","button_7_button_hover":"#4e8221","button_7_link_colour":"#fff","button_7_as_button":"1","button_7_new_win":"","font_family":"inherit","header_fix":"","notify_animate_hide":"1","notify_animate_show":"","notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":"","scroll_close_reload":"","accept_close_reload":"","reject_close_reload":"","showagain_tab":"","showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#333333","show_once_yn":"","show_once":"10000","logging_on":"","as_popup":"","popup_overlay":"1","bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"};
var log_object = {"ajax_url":"https:\/\/idahobusinessreview.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js' id='cookie-law-info-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js' id='stop-user-enumeration-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/tdc-paywall-psa/login_popup.js' id='dmcss_login_popup-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/tdc-paywall-psa/login_form.js' id='dmcss_login_form-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js' id='gtm4wp-form-move-tracker-js'></script>
<script type='text/javascript' id='google_ad_js-js-extra'>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</script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/asn-dfp-ads/assets/js/google-ads.min.js' id='google_ad_js-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/asn-dfp-ads/assets/js/dfp-ads.min.js' id='dfp_ads-js'></script>
<link rel="https://api.w.org/" href="https://idahobusinessreview.com/wp-json/" /><link rel="alternate" type="application/json" href="https://idahobusinessreview.com/wp-json/wp/v2/posts/284145" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://idahobusinessreview.com/xmlrpc.php?rsd" />
<link rel='shortlink' href='https://idahobusinessreview.com/?p=284145' />
<link rel="alternate" type="application/json+oembed" href="https://idahobusinessreview.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fidahobusinessreview.com%2F2022%2F08%2F26%2Fbiz-bite-boise-buys-mobile-home-park%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://idahobusinessreview.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fidahobusinessreview.com%2F2022%2F08%2F26%2Fbiz-bite-boise-buys-mobile-home-park%2F&#038;format=xml" />

<meta name='google-site-verification' content='pdIfxBOwt8N_Zpc5UZ3AIrXpeYa5v0h0Jnr8IiS1W-A' />
<meta name='y_key' content='877cbb0bd73c44cd' />
<meta name='msvalidate.01' content='3999BB2D894623F4AF6815FACA6133D9' />
<meta name="generator" content="WordPress" /><style>.post-thumbnail img[src$='.svg'] { width: 100%; height: auto; }</style>
<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://idahobusinessreview.com/feed/podcast" />


<meta name="author" content="IBR Staff" />
        <script>
            wpsolr_globalError = [];
            window.onerror = function (msg, url, line, col, error) {
                wpsolr_globalError.push({msg: msg, url: url, line: line, error: error});
            };
        </script>
		
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["ibr-headlines","news","real-estate"],"pagePostAuthor":"IBR Staff"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK6J63');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><link rel="shortcut icon" href="https://idahobusinessreview.com/files/2020/01/IBR_favicon_32x32.png" title="Favicon" /><!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://idahobusinessreview.com/wp-content/themes/jarida/js/html5.js"></script>
<script src="https://idahobusinessreview.com/wp-content/themes/jarida/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://idahobusinessreview.com/wp-content/themes/jarida/css/ie8.css" />
<![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
	<meta name="viewport" content="width=device-width, initial-scale=1" />
	<style type="text/css" media="screen">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</style>
<!-- BEGIN Krux ControlTag for "idahobusinessreview.com" -->
<script class="kxct" data-id="slrsd1f0i" data-timing="async" data-version="3.0" type="text/javascript">
  window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
  (function(){
    var k=document.createElement('script');k.type='text/javascript';k.async=true;
    k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/slrsd1f0i.js';
    var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
  }());
jQuery(document).ready(function($){
jQuery("li:contains('welcome ad')").hide();
jQuery("#top-posts-2").show();

});
</script>
<!-- END Krux ControlTag -->

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK6J63');</script>
<!-- End Google Tag Manager -->

<link rel='stylesheet' id='j_idahobusinessreview-css'  href='/wp-content/mu-plugins/site_css/idahobusinessreview/1/j_idahobusinessreview.css' type='text/css' media='all' />
<link rel='stylesheet' id='site_nonspecific-css'  href='/wp-content/mu-plugins/site_css/common.css' type='text/css' media='all' />
<script type='text/javascript' src='https://button.flattr.com/loader.js?mode=auto'></script>
<style>
img#wpstats { position: absolute; top: 0; width: 0px; height: 0px; overflow: hidden; }
body{
background-color:#fff !important; 
}
#top-posts-2{display:none;}
</style>


<!-- Google Analytics Tracking by Google Analyticator  -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'disabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-10379233-4', 'auto');
 
	ga('send', 'pageview');
	_gaq.push(['_setDomainName', 'https://idahobusinessreview.com/']);

</script>


<!-- BetterSMB Ads Code -->

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21669907858/BTM_BetterSMB_Network_165x250', [165, 250], 'div-gpt-ad-1576771635613-0').addService(googletag.pubads());
	googletag.defineSlot('/21669907858/BTM_BetterSMB_Network_300x200', [300, 200], 'div-gpt-ad-1576771721921-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- Jarida include the function for subscribe iframe -->
<script>
jQuery(document).ready(function () {   
       jQuery("#form_opening iframe").attr("scrolling", "yes");
       jQuery("#form_opening iframe").attr("OVERFLOW", "auto");       	   
});
</script>

<script>(function(d){var s = d.createElement("script");s.setAttribute("data-account", "OL9je7qAhU");s.setAttribute("src", "https://cdn.userway.org/widget.js");(d.body || d.head).appendChild(s);})(document)</script><noscript>Please ensure Javascript is enabled for purposes of <a href="https://userway.org">website accessibility</a></noscript>

<!-- Bombora Visitor Insight Code for https://idahobusinessreview.com/  -->
  <script>
(function (w,d,t) {
  _ml = w._ml || {};
  _ml.eid = '87440';
  var s, cd, tag; s = d.getElementsByTagName(t)[0]; cd = new Date();
  tag = d.createElement(t); tag.async = 1;
  tag.src = 'https://ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth();
  s.parentNode.insertBefore(tag, s);
})(window,document,'script');
</script>
<!-- Bombora Visitor Insight Code for https://idahobusinessreview.com/ end -->


<!-- BlueConic code start-->
<script src="https://x439.idahobusinessreview.com/script.js"></script>
<!-- BlueConic code end-->

<script>
 function loadScript(tagSrc) {
 var scriptTag = document.createElement('script'),
 placeTag = document.getElementsByTagName("script")[0];
 scriptTag.type = 'text/javascript';
 scriptTag.async = true;
 scriptTag.src = tagSrc;
 placeTag.parentNode.insertBefore(scriptTag, placeTag);
 }
 window.mnjs = window.mnjs || {
 customerId: "8CUJ112MK",
 domain: window.location.hostname,
 failSafeTimeout: 3e3,
 version: 1.0,
 isAdServerLoaded: false
 };
 var mnjsEndpoint = 'https://warp.media.net/js/tags/clientag.js?' +
 'cid=' + window.mnjs.customerId +
 '&dn=' + window.mnjs.domain +
 '&version=' + window.mnjs.version;
 loadScript(mnjsEndpoint);
 window.mnjs.loadAdServer = setTimeout(function() {
 if (!window.mnjs.isAdServerLoaded) {
 loadScript("https://www.googletagservices.com/tag/js/gpt.js");
 window.mnjs.isAdServerLoaded = true;
 }
 }, window.mnjs.failSafeTimeout);
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
</script>

<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '2117158435253744', {}, {
    "agent": "wordpress-5.9.2-3.0.6"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=2117158435253744&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!-- Start of Act On Beacon Code -->
<script>/*<![CDATA[*/(function(w,a,b,d,s){w[a]=w[a]||{};w[a][b]=w[a][b]||{q:[],track:function(r,e,t){this.q.push({r:r,e:e,t:t||+new Date});}};var e=d.createElement(s);var f=d.getElementsByTagName(s)[0];e.async=1;e.src='//news.idahobusinessreview.com/cdnr/50/acton/bn/tracker/22733';f.parentNode.insertBefore(e,f);})(window,'ActOn','Beacon',document,'script');ActOn.Beacon.track();/*]]>*/</script>
<!-- End of Act On Beacon Code -->
		<style type="text/css" id="wp-custom-css">
			 @media only screen and (max-width: 767px){.top-nav .top-menu {display: block !important;}
  .top-nav .top-menu ul:first-child {display: block !important;}
 .top-nav .top-menu ul li {display: none;}
.top-nav .top-menu ul li:last-child {display: block;position: absolute;top: 1px;margin-left: -64px;}
.top-nav .top-menu ul li:last-child .zephr-login summary {padding: 7px 14px;}
.search-block #s {
  width: 135px;
}
}		</style>
		<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body id="top" class="post-template-default single single-post postid-284145 single-format-standard ibr-headlines news real-estate subscriber_only wpb-js-composer js-comp-ver-6.7.0 vc_responsive">
	<div class="background-cover"></div>
	<div class="wrapper full-site">
				<div class="top-nav fade-in animated1 head_brnews">
			<div class="container">
				<div class="search-block">
					<form method="get" id="searchform" action="https://idahobusinessreview.com/">
						<button class="search-button" type="submit" value="Search"></button>
						<input type="text" id="s" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}"  />
					</form>
				</div><!-- .search-block /-->
					<div class="social-icons icon_flat">
		<a class="tooldown" title="Rss" href="https://idahobusinessreview.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="tooldown" title="Facebook" href="https://www.facebook.com/IdahoBusinessReview/" target="_blank"><i class="tieicon-facebook"></i></a><a class="tooldown" title="Twitter" href="https://twitter.com/IBRnews" target="_blank"><i class="tieicon-twitter"></i></a><a class="tooldown" title="LinkedIn" href="https://www.linkedin.com/company/idaho-business-review" target="_blank"><i class="tieicon-linkedin"></i></a><a class="tooldown" title="Youtube" href="https://www.youtube.com/channel/UC59PCuG4AfDCN_TkgX26x2A" target="_blank"><i class="tieicon-youtube"></i></a><a class="tooldown" title="instagram" href="https://www.instagram.com/ibrnews/" target="_blank"><i class="tieicon-instagram"></i></a><a class="tooldown" title="photo" href="http://www.idahobusinessreview.smugmug.com/" target="_blank"><i class="tieicon-photo"></i></a>	</div>

	
				            <div class="form-horizontal shadow dmcss_login_form" id="popup_loginform">
            				<form name="loginform" class="loginform" style="text-align:left" id="loginform" action="https://idahobusinessreview.com/adminlogin/?wpe-login=true" method="post">			<div class="field">
				<label for="dmcss_user">Email Address/USER ID:</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" tabindex="10" />
			</div>			<div class="field">
				<label for="dmcss_pass">Password:</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" tabindex="20" />
			</div>			<p class="submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button-primary button " value="Log In" tabindex="100" />				<input type="hidden" name="rememberme" value="1" />
				<input type="hidden" name="redirect_to" value="/2022/08/26/biz-bite-boise-buys-mobile-home-park/" />
			</p>
		</form>
		
		
					<div class="links">			</div>            </div><div class="top-menu"><ul id="menu-subscribe" class="menu"><li id="menu-item-110371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110371"><a href="https://idahobusinessreview.com/subscribe">Subscribe</a></li>
<li id="menu-item-110373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-110373"><a href="#">Manage Account</a>
<ul class="sub-menu">
	<li id="menu-item-219118" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219118"><a href="https://idahobusinessreview.com/manage-account-fc/">Manage Your Print or Online Subscription</a></li>
	<li id="menu-item-219114" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219114"><a href="https://idahobusinessreview.com/manage-account-em/">Manage Your Email Subscription</a></li>
</ul>
</li>
<li><a href="/2022/08/26/biz-bite-boise-buys-mobile-home-park/?dmcss=login">LOG IN</a></li></ul></div>	
	<div class="breaking-news">
		<span>Don't Miss</span>
				
					<ul>
							<li><a href="https://idahobusinessreview.com/2022/08/26/biz-bite-aha-started-flights-to-idaho-falls-then-went-under/" title="Biz &#8216;Bite:&#8217; aha! started flights to Idaho Falls, then went under&nbsp;">Biz &#8216;Bite:&#8217; aha! started flights to Idaho Falls, then went under&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/" title="Biz &#8216;Bite:&#8217; Boise buys mobile home park&nbsp;">Biz &#8216;Bite:&#8217; Boise buys mobile home park&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="https://idahobusinessreview.com/2022/08/26/military-families-housing-benefits-lag-as-rents-explode/" title="Military families&#8217; housing benefits lag as rents explode&nbsp;">Military families&#8217; housing benefits lag as rents explode&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="https://idahobusinessreview.com/2022/08/26/29-of-idaho-grads-eligible-of-20000-student-loan-relief/" title="29% of Idaho grads eligible of $20,000 student loan relief&nbsp;">29% of Idaho grads eligible of $20,000 student loan relief&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="https://idahobusinessreview.com/2022/08/26/marzocco-joins-the-mike-brown-group/" title="Marzocco joins The Mike Brown Group&nbsp;">Marzocco joins The Mike Brown Group&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="https://idahobusinessreview.com/2022/08/26/military-families-housing-benefits-lag-as-rents-explode-2/" title="Military families&#8217; housing benefits lag as rents explode&nbsp;">Military families&#8217; housing benefits lag as rents explode&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="https://idahobusinessreview.com/2022/08/25/biz-bite-no-cost-idaho-small-business-development-center-class/" title="Biz &#8216;Bite:&#8217; no-cost Idaho Small Business Development Center class&nbsp;">Biz &#8216;Bite:&#8217; no-cost Idaho Small Business Development Center class&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="https://idahobusinessreview.com/2022/08/25/3-join-b-a-harris/" title="3 join B.A. Harris&nbsp;">3 join B.A. Harris&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
							<li><a href="https://idahobusinessreview.com/2022/08/25/idaho-department-of-lands-sells-10-priest-lake-lots-for-24-6-million/" title="Idaho Department of Lands sells 10 Priest Lake lots for $24.6 million">Idaho Department of Lands sells 10 Priest Lake lots for $24.6 million</a></li>
							<li><a href="https://idahobusinessreview.com/2022/08/25/what-to-expect-when-youre-expecting-a-recession/" title="What to expect when you’re expecting a recession&nbsp;">What to expect when you’re expecting a recession&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
						</ul>
					
						<script type="text/javascript">
			jQuery(document).ready(function(){
								jQuery('.breaking-news ul').innerfade({animationtype: 'fade', speed: 750 , timeout: 3500});
							});
		</script>
	</div> <!-- .breaking-news -->				
								<div class="top-menu-liney" style="display:none;">
					<a class="top-menu-footer-liney"  href="#footer-top-menu-liney" >
											</a>
				</div>
								
				
			</div>
		</div><!-- .top-menu /-->
		
		<div class="container">
		<header id="theme-header">
		<div class="header-content fade-in animated1">
			<div class="logo" style="margin-top:15px">
			<h2>
																<a title="Idaho Business Review" href="https://idahobusinessreview.com/">
					<img onerror="this.src='https://idahobusinessreview.com/files/2020/01/IBR.png';this.onerror=null;" src="https://idahobusinessreview.com/files/2020/01/IBR.svg" alt="Idaho Business Review" /><strong>Idaho Business Review IBR</strong>
				</a>
			</h2>			</div><!-- .logo /-->
					<div class="e3lan-top">					<div class="top-ad-desktop">
<!-- idahobusiness -->		<div id="div-gpt-ad-top_leaderboard"
		     class="div-gpt-ad-top_leaderboard idahobusiness dfp_ad_pos">
			<script type='text/javascript'>
				googletag.cmd.push(function () {
					googletag.display('div-gpt-ad-top_leaderboard');
					googletag.pubads().collapseEmptyDivs(true);
				});
			</script>
		</div>
		
</div>

<div class="top-ad-mobile">
<!-- idahobusiness -->		<div id="div-gpt-ad-top_leaderboard_mobile"
		     class="div-gpt-ad-top_leaderboard_mobile idahobusiness dfp_ad_pos">
			<script type='text/javascript'>
				googletag.cmd.push(function () {
					googletag.display('div-gpt-ad-top_leaderboard_mobile');
					googletag.pubads().collapseEmptyDivs(true);
				});
			</script>
		</div>
		
</div>				</div>			<div class="clear"></div>
		</div>
									<nav id="main-nav" class="fade-in animated2 fixed-enabled">
				<div class="container">
				<div class="main-menu"><ul id="menu-news" class="menu"><li id="menu-item-109531" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-home"><a href="https://idahobusinessreview.com/">Home</a></li>
<li id="menu-item-109521" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent  menu-item-has-children"><a href="https://idahobusinessreview.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-140308" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/digital-edition/">Digital Edition&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
	<li id="menu-item-227244" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="https://idahobusinessreview.com/category/news/business-news/">Business News</a>
	<ul class="sub-menu">
		<li id="menu-item-222214" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/news/q-a/">Q &amp; A</a></li>
		<li id="menu-item-229642" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/news/small-business-spotlight/">Small Business Spotlight</a></li>
		<li id="menu-item-199249" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/people/">People</a></li>
		<li id="menu-item-238031" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/ibr-outloud/">Idaho Business Out Loud</a></li>
	</ul> <!--End Sub Menu -->
</li>
	<li id="menu-item-129934" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="https://idahobusinessreview.com/category/news/construction/">Construction News</a>
	<ul class="sub-menu">
		<li id="menu-item-276516" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://idahobusinessreview.com/building-permits/">Building Permits</a></li>
	</ul> <!--End Sub Menu -->
</li>
	<li id="menu-item-229637" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/news/financial-services/">Financial Services News</a></li>
	<li id="menu-item-229639" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/news/health-care/">Health Care News</a></li>
	<li id="menu-item-229640" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/news/law-government/">Law &#038; Government News</a></li>
	<li id="menu-item-273731" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="#">Real Estate News</a>
	<ul class="sub-menu">
		<li id="menu-item-176103" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/news/roundup/">Roundup</a></li>
		<li id="menu-item-217013" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/market-snapshot/">Market Snapshot</a></li>
	</ul> <!--End Sub Menu -->
</li>
	<li id="menu-item-229644" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="https://idahobusinessreview.com/category/news/technology/">Technology News</a>
	<ul class="sub-menu">
		<li id="menu-item-229643" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/news/techbytes/">Techbytes</a></li>
	</ul> <!--End Sub Menu -->
</li>
	<li id="menu-item-110166" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://idahobusinessreview.com/category/commentary/">Commentary</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-194705" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="https://idahobusinessreview.com/events/">Events &#038; Pubs</a>
<ul class="sub-menu">
	<li id="menu-item-109543" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/events/woy/">Women of the Year</a></li>
	<li id="menu-item-109535" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/events/ceo/">CEO of Influence</a></li>
	<li id="menu-item-109533" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/events/au40/">Accomplished Under 40</a></li>
	<li id="menu-item-211193" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/icon/">Icon Awards</a></li>
	<li id="menu-item-277276" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/top-companies-in-treasure-valley/">Top Companies in Treasure Valley</a></li>
	<li id="menu-item-109541" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/events/excellence-in-finance/">Excellence in Finance</a></li>
	<li id="menu-item-109542" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/events/tp/">Top Projects</a></li>
	<li id="menu-item-110318" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/events/leaders-in-law/">Leaders in Law</a></li>
	<li id="menu-item-109537" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/breakfast-series/">Breakfast Series</a></li>
	<li id="menu-item-249824" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/business-beyond-the-blip/">Business Beyond the Blip Webinars</a></li>
	<li id="menu-item-211226" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/experts-forum/">Experts Forum</a></li>
	<li id="menu-item-204464" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/forum-on-the-future/">Forum On the Future</a></li>
	<li id="menu-item-194713" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://idahobusinessreview.com/events/award-nomination-forms/">Nomination Forms</a></li>
	<li id="menu-item-160013" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://idahobusinessreview.com/events/award-applications/">Awards applications</a></li>
	<li id="menu-item-130416" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://idahobusinessreview.smugmug.com">Event Photos</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-130036" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="https://idahobusinessreview.com/ibr-special-publications/">Other Publications</a>
<ul class="sub-menu">
	<li id="menu-item-109538" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/bol/">Book of Lists&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></li>
	<li id="menu-item-190455" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/reader-rankings/">Reader Rankings</a></li>
	<li id="menu-item-109536" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/guide/">Corporate Event Planners’ Guide</a></li>
	<li id="menu-item-257696" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/power-25-2/">Power Lists</a></li>
	<li id="menu-item-151130" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://idahobusinessreview.com/square-feet/">Square Feet</a></li>
	<li id="menu-item-265307" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://www.pageturnpro.com/Idaho-Business-Review/99095-Rebound-and-Recover-2021/sdefault.html">Rebound + Recover</a></li>
	<li id="menu-item-109540" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/state-of-downtown-boise/">Downtown Boise</a></li>
	<li id="menu-item-110317" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/ccim-directory/">CCIM Directory</a></li>
	<li id="menu-item-232231" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/milestones/">Milestones</a></li>
	<li id="menu-item-110312" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/treasure-valley-living/">Treasure Valley Living</a></li>
	<li id="menu-item-110315" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/heartland-living/">Idaho Heartland Living</a></li>
	<li id="menu-item-161751" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/mccall-map/">Idaho Heartland Living Map</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-111134" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://idahobusinessreview.com/book-of-lists4/?djoPage=products">TopLists</a></li>
<li id="menu-item-109527" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/about/advertising/">Advertising</a></li>
<li id="menu-item-279248" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://enveritasgroup.com/idahobusinessreview">Reprints</a></li>
<li id="menu-item-241801" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/about/contact-us/">Contact Us</a></li>
<li id="menu-item-252878" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="https://idahobusinessreview.com/webinars/">Webinars</a>
<ul class="sub-menu">
	<li id="menu-item-252879" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/idaho-business-now-webinar-series/">Idaho Business Now Webinar Series</a></li>
	<li id="menu-item-252880" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/experts-forum/">Experts Forum</a></li>
	<li id="menu-item-252884" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://idahobusinessreview.com/business-beyond-the-blip/">Business Beyond the Blip</a></li>
</ul> <!--End Sub Menu -->
</li>
</ul></div>				</div>
			</nav><!-- .main-nav /-->
		</header><!-- #header /-->

	<div id="main-content" class="container fade-in animated3 sidebar-narrow-left">
		<div id="content-background-cover" class="mobile-menu-background-cover"></div><div class="content-wrap">
	<div class="content">
        <div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://idahobusinessreview.com"><i class="tieicon-home"></i>Home</a></span> / <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://idahobusinessreview.com/category/ibr-headlines/">IBR Headlines</a></span> / <span class="current">Biz &#8216;Bite:&#8217; Boise buys mobile home park&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></span></div>		
		
				
						
		<article id="the-post" class="post-listing hnews hentry item post-284145 post type-post status-publish format-standard has-post-thumbnail category-ibr-headlines category-news category-real-estate subscriber_only">
				

			<div class="post-inner">
             				<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">Biz &#8216;Bite:&#8217; Boise buys mobile home park&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></span></h1>
                             
						
<p class="post-meta">
		
	<span class="post-meta-author">By:  <a href="https://idahobusinessreview.com/author/ibrstaff/" title="">IBR Staff</a>	
	
	</span>
    	
		
	 <span class="tie-date">August 26, 2022</span>	
	<span class="post-comments"><a href="https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/#respond">0</a></span>
</p>
<div class="clear"></div>
	
				<div class="entry entry-content">
					
					In its efforts to preserve affordable housing for its residents, the City of Boise announced that it purchased the Sage Mobile Home Park in the Boise Bench neighborhood on Aug. 25. The two-acre property is near Shoshone Park with less than 200 feet walking distance to “best-in-class transit” available on Vista Avenue.

The residents of the ...<div class="dmcss_login_form">		<div id = "before_login_text">
		<div class="message"><em>Complete access to news articles on idahobusinessreview.com is available to Idaho Business Review subscribers who are logged in. Subscribers may login at the login tab below. Others may <a href="http://idahobusinessreview.com/subscribe" target="_blank">join our audience with a subscription today</a>.</em></div>
		</div>
				
		<div id="form_tabs">
			<div id="form_nav">
			<ul id="dmcss_tabs">					<li id="subscribe_tab" class="active_tab"><a id="subscribe_link" href="#subscribe_div">Subscribe</a></li>				<li id="login_tab" ><a id="login_link" href="#login_div">Login</a></li>
			</ul>
			</div>
			<div id="subscribe_div" class="dmcss_tab_div active_tab"><style>
    .subscribe_option {
        margin: auto;
        text-align:center;
        display: none;
    }
    .subscribe_option .option_listing {
        width:155px;
        float:left;
        margin-bottom:15px;
    }
    .subscribe_option a {
        text-decoration:none;
        visited:#444444;
        hover:#444444;
    }
    .subscribe_option #guarantee {
        display: block;
        float: left;
        width: 330px;
    }
    #subscribe-small > div {
        float: none;
        margin: auto;
    }
    @media only screen and (min-width: 769px) {
        #subscribe_div {width: 500px;}
        #subscribe-large {display: block;}
        #subscribe-small .active {display: none;}
    }
    @media only screen and (max-width: 769px) {
        #subscribe_div {width: 100%;}
        #subscribe-large {display: none;}
        #subscribe-small {display: block;}
        #subscribe-small .subscribe_image {display: none;}
        .dmcss_login_form .dmcss_tab_div {padding: 0;}
    }
</style>
<center>
<div align="center" class="pw-large" id="subscribe-large">
          
                <!-- *************** -->
                <div id="subscribe_option1" class="subscribe_option" >
                    <div class="option_listing" style="width:80px; float:left; border:1px solid #CCCCCC; margin-bottom:15px; padding:3px;">
                        <strong>Print, Digital & Mobile<br><br><a href="https://idahobusinessreview.com/printdigital/?promocode=WZZPAYWM" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444; color:#1D4E72">1 Month<br>Intro Rate<br>$11.99</a><br>----------<br><a href="https://idahobusinessreview.com/printdigital/?promocode=WZZPAYW" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444; color:#1D4E72">1 Year<br>$169</a><br></strong>
                    </div>
                    <div class="option_listing" style="width:300px; float:left; border:0px solid #CCCCCC; margin-left:11px; margin-bottom:15px;">
                        <a href="https://idahobusinessreview.com/subscription-premium/?promocode=WZFPREM" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444;">
                        <img src="https://idahobusinessreview.com/files/2020/06/IBR-ListData_300x250-V3.png" border="0">
                        </a>
                    </div>
                    <div class="option_listing" style="width:80px; float:left; margin-left:11px; border:1px solid #CCCCCC; padding:3px;">
                        <strong>Digital & Mobile Only<br><br><a href="https://idahobusinessreview.com/printdigital/?promocode=WZZPAYWD" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444; color:#1D4E72">1 Year<br>$119</a><br></strong>
                    </div>
                </div> <!-- pw_subscribe1 -->
                <!-- *************** -->
                <div  id="subscribe_option2" class="subscribe_option" >
                    <div class="option_listing" style="width:80px; float:left; border:1px solid #CCCCCC; margin-bottom:15px; padding:3px;">
                        <strong>Digital & Mobile Only<br><br><a href="https://idahobusinessreview.com/printdigital/?promocode=WZZPAYWD" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444; color:#1D4E72">1 Year<br>$119</a><br></strong>
                    </div>
                    <div class="option_listing" style="width:300px; float:left; border:0px solid #CCCCCC; margin-left:11px; margin-bottom:15px;">
                        <a href="https://idahobusinessreview.com/subscription-premium/?promocode=WZFPREM" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444;">
                        <img src="https://idahobusinessreview.com/files/2020/06/IBR-ListData_300x250-V3.png" border="0">
                        </a>
                    </div>
                    <div class="option_listing" style="width:80px; float:left; margin-left:11px; border:1px solid #CCCCCC; padding:3px;">
                        <strong>Print, Digital & Mobile<br><br><a href="https://idahobusinessreview.com/printdigital/?promocode=WZZPAYWM" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444; color:#1D4E72">1 Month<br>Intro Rate<br>$11.99</a><br>----------<br><a href="https://idahobusinessreview.com/printdigital/?promocode=WZZPAYW" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444; color:#1D4E72">1 Year<br>$169</a><br></strong>
                    </div>
                </div> <!-- pw_subscribe2 -->
                <!-- *************** -->
             <!-- pw-large -->
            <!-- *************** -->
</div>
</center>
            <br style="clear:both;" />
        <center>
            <!-- *************** -->
            <div  id="subscribe-small" class="subscribe_option" align="center">
                <div class="option_listing subscribe_image" style="width:300px; float:center; border:0px solid #CCCCCC; margin-bottom:15px;">
                    <a href="https://idahobusinessreview.com/subscription-premium/?promocode=WZFPREM" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444;">
                    <img src="https://idahobusinessreview.com/files/2020/06/IBR-ListData_300x250-V3.png" border="0">
                    </a>
                </div>
                <div class="option_listing" style="width:200px; float:center; border:1px solid #CCCCCC; margin-bottom:15px; padding:3px;">
                    <strong>Print, Digital & Mobile<br><br><a href="https://idahobusinessreview.com/printdigital/?promocode=WZZPAYWM" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444; color:#1D4E72">1 Month<br>Intro Rate<br>$11.99</a><br>----------<br><a href="https://idahobusinessreview.com/printdigital/?promocode=WZZPAYW" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444; color:#1D4E72">1 Year<br>$169</a><br>----------<br>Digital & Mobile Only<br><br><a href="https://idahobusinessreview.com/printdigital/?promocode=WZZPAYWD" target="_blank" style="text-decoration:none; visited:#444444; hover:#444444; color:#1D4E72">1 Year<br>$119</a><br></strong>
                </div>
            </div> <!-- pw_small -->
            <!-- *************** -->
        </center>
    <!-- *************** -->


<script type="text/javascript" language="Javascript">
    var pwWhichDiv = Math.floor(Math.random(2)*2)==1?"subscribe_option1":"subscribe_option2";
    document.getElementById(pwWhichDiv).style.display='block';
</script>			</div>			<div id="login_div" class="dmcss_tab_div ">		<style>
  .dmcss_login_form label {
   width : 195px !important;
        }
	#login_div {
		border: 1px solid rgb(68, 68, 68);
		padding-top: 10px;
		padding-bottom: 20px;
		margin-bottom: 15px;
		margin-top: 15px;
		background-color: rgb(239, 239, 239);
	}
      .dmcss_login_form label { font-weight:bold;width:150px;}
#main-content input[type="submit"] {background-color: #0055a5 !important;}
</style>
		<form name="loginform" class="loginform" style="text-align:left" id="loginform" action="https://idahobusinessreview.com/adminlogin/?wpe-login=true" method="post">			<div class="field">
				<label for="dmcss_user">Email Address/USER ID:</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" tabindex="10" />
			</div>			<div class="field">
				<label for="dmcss_pass">Password:</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" tabindex="20" />
			</div>			<p class="submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button-primary button " value="Log In" tabindex="100" />				<input type="hidden" name="rememberme" value="1" />
				<input type="hidden" name="redirect_to" value="/2022/08/26/biz-bite-boise-buys-mobile-home-park/" />
			</p>
		</form>
		
		
		
<p> Enter your email address/USER ID and password in the fields above to gain access to the subscriber content on this site.  

<p>Your subscription includes one set of login credentials for your exclusive use.  Security features have been integrated on this site: If someone signs in with your credentials while you are logged in, the site will automatically close your ongoing login and you will lose access at that time.  To inquire about group subscriptions for your organization, contact <b style="font-size: 12px;margin-left: 1px;"><a href="/cdn-cgi/l/email-protection#2655514f52526644544f42414352495143544b43424f470845494b">Shaun Witt</a></b>.</p><div></div>
<p>Already a paid subscriber but not registered for online access yet? <b style="font-size: 12px;margin-left: 1px;"><a href="/already-a-subscriber/" target="_blank">Click Here to register</a></b>.</p>
<p><b style="font-size: 12px;"><a href="http://idahobusinessreview.com/forgot-password">Forgot password or User ID?</a></b></p>
			</div>
		</div></div><div class="article_dfp_ads article_dfp_ads_non_login global"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script><script>
googletag.cmd.push(function() {
googletag.defineSlot("13051489/idahobusiness/incontent", [300, 250], "div-gpt-ad-incontent").addService(googletag.pubads());
googletag.pubads().setTargeting("pos",["incontent"]);
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs(true);
googletag.enableServices();

});
</script>
<div id="div-gpt-ad-incontent" align="center">
<script>
googletag.cmd.push(function() { googletag.display("div-gpt-ad-incontent"); });
</script>
</div></div><br>										
					
									</div><!-- .entry /-->
				                <span style="display:none" class="updated" title="2022-08-26T12:04:11Z">12:04 pm Fri, August 26, 2022</span>
                <span class="source-org vcard" style="display:none;"><a class="org fn" href="https://idahobusinessreview.com">Idaho Business Review</a></span>								<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="https://idahobusinessreview.com/author/ibrstaff/" title="Posts by IBR Staff" rel="author">IBR Staff</a></strong></div>
								
				<div class="share-post">
	<script>
	window.___gcfg = {lang: 'en-US'};
	(function(w, d, s) {
	  function go(){
		var js, fjs = d.getElementsByTagName(s)[0], load = function(url, id) {
		  if (d.getElementById(id)) {return;}
		  js = d.createElement(s); js.src = url; js.id = id;
		  fjs.parentNode.insertBefore(js, fjs);
		};
		load('//connect.facebook.net/en/all.js#xfbml=1', 'fbjssdk');
		load('https://apis.google.com/js/plusone.js', 'gplus1js');
		load('//platform.twitter.com/widgets.js', 'tweetjs');
	  }
	  if (w.addEventListener) { w.addEventListener("load", go, false); }
	  else if (w.attachEvent) { w.attachEvent("onload",go); }
	}(window, document, 'script'));
	</script>
	<ul>			
			<li><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/" data-text="Biz &#8216;Bite:&#8217; Boise buys mobile home park&nbsp;" data-via="" data-lang="en">tweet</a></li>
							<li><script src="https://platform.linkedin.com/in.js" type="text/javascript"></script><script type="IN/Share" data-url="https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/" data-counter="right"></script></li>
			</ul>
	<div class="clear"></div>
</div> <!-- .share-post -->				
			</div><!-- .post-inner -->
		</article><!-- .post-listing -->
		        
		
				
						
		<div class="post-navigation">
			<div class="post-previous"><a href="https://idahobusinessreview.com/2022/08/26/military-families-housing-benefits-lag-as-rents-explode/" rel="prev"><span>Previous:</span> Military families&#8217; housing benefits lag as rents explode&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></div>
			<div class="post-next"><a href="https://idahobusinessreview.com/2022/08/26/biz-bite-aha-started-flights-to-idaho-falls-then-went-under/" rel="next"><span>Next:</span> Biz &#8216;Bite:&#8217; aha! started flights to Idaho Falls, then went under&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></div>
		</div><!-- .post-navigation -->
				
				
		<section id="author-box">
			<div class="block-head">
				<h3>About IBR Staff </h3>
			</div>
			<div class="post-listing">
						<div class="author-avatar">
			<img alt='' src='https://secure.gravatar.com/avatar/0633638b408ca148b5deceab7d864a53?s=60&#038;r=pg' srcset='https://secure.gravatar.com/avatar/0633638b408ca148b5deceab7d864a53?s=120&#038;r=pg 2x' class='avatar avatar-60 photo' height='60' width='60' loading='lazy'/>		</div><!-- #author-avatar -->
		<div class="author-description">
			</div><!-- #author-description -->
			<div class="author-social">
							<a class="ttip" href="http://" title="IBR Staff 's site"><img src="https://idahobusinessreview.com/wp-content/themes/jarida/images/author_site.png" width="18" height="18" alt="" /></a>
																																</div>
		<div class="clear"></div>
				</div>
		</section><!-- #author-box -->
		
			

		
                		<div id="comments">



	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply</h3><form action="https://idahobusinessreview.com/wp-comments-post.php?wpe-comment-post=ibrprod" method="post" id="commentform" class="comment-form"><p class="comment-notes">Your email address will not be published. Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <span class="required">*</span><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email</label> <span class="required">*</span><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='284145' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="87aab54608" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="38"/><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
        	
	</div><!-- .content -->
<aside class="sidebar-narrow">
<div id="text-1071291135" class="widget widget_text"><div class="widget-top"><h4>Job Postings</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget"><p><a href="https://idahobusinessreview.com/job-postings/"><img src="https://idahobusinessreview.com/files/2020/04/now-hiring-1.png" style="text-align: center !important;"></a><br />
Looking for a job? Looking to fill new positions at your company?</p>
</div>
		</div></div><!-- .widget /--><div id="text-html-widget-31" class="widget text-html"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div ><a href="https://idahobusinessreview.com/business-announcements/people-submission-form/"><img class="aligncenter size-full wp-image-251401" src="https://idahobusinessreview.com/files/2020/06/submit-people.jpg" alt="" width="126" height="48" /></a>
				</div><div class="clear"></div></div></div><!-- .widget /--><div id="categort-posts-widget-8" class="widget categort-posts"><div class="widget-top"><h4><a href="https://idahobusinessreview.com/category/people/">People</a>		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2022/08/26/marzocco-joins-the-mike-brown-group/" title="Permalink to Marzocco joins The Mike Brown Group&nbsp;" rel="bookmark"><img width="70" height="70" src="https://idahobusinessreview.com/files/2022/08/Marzocco-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" srcset="https://idahobusinessreview.com/files/2022/08/Marzocco-70x70.jpg 70w, https://idahobusinessreview.com/files/2022/08/Marzocco-300x300.jpg 300w, https://idahobusinessreview.com/files/2022/08/Marzocco.jpg 600w, https://idahobusinessreview.com/files/2022/08/Marzocco-175x175.jpg 175w, https://idahobusinessreview.com/files/2022/08/Marzocco-200x200.jpg 200w, https://idahobusinessreview.com/files/2022/08/Marzocco-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2022/08/26/marzocco-joins-the-mike-brown-group/">Marzocco joins The Mike Brown Group&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">August 26, 2022</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2022/08/25/3-join-b-a-harris/" title="Permalink to 3 join B.A. Harris&nbsp;" rel="bookmark"><img width="70" height="70" src="https://idahobusinessreview.com/files/2022/08/headshots1-1-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" srcset="https://idahobusinessreview.com/files/2022/08/headshots1-1-70x70.jpg 70w, https://idahobusinessreview.com/files/2022/08/headshots1-1-200x200.jpg 200w, https://idahobusinessreview.com/files/2022/08/headshots1-1-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2022/08/25/3-join-b-a-harris/">3 join B.A. Harris&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">August 25, 2022</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2022/08/24/stillion-joins-titleone/" title="Permalink to Stillion joins TitleOne&nbsp;" rel="bookmark"><img width="70" height="70" src="https://idahobusinessreview.com/files/2022/08/Stillion-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" srcset="https://idahobusinessreview.com/files/2022/08/Stillion-70x70.jpg 70w, https://idahobusinessreview.com/files/2022/08/Stillion-200x200.jpg 200w, https://idahobusinessreview.com/files/2022/08/Stillion-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2022/08/24/stillion-joins-titleone/">Stillion joins TitleOne&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">August 24, 2022</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2022/08/24/d-l-evans-bank-promotes-shurtz/" title="Permalink to D.L. Evans Bank promotes Shurtz" rel="bookmark"><img width="70" height="70" src="https://idahobusinessreview.com/files/2022/08/Shurtz-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" srcset="https://idahobusinessreview.com/files/2022/08/Shurtz-70x70.jpg 70w, https://idahobusinessreview.com/files/2022/08/Shurtz-200x200.jpg 200w, https://idahobusinessreview.com/files/2022/08/Shurtz-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2022/08/24/d-l-evans-bank-promotes-shurtz/">D.L. Evans Bank promotes Shurtz</a></h3>
			 <span class="date"><span class="tie-date">August 24, 2022</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2022/08/23/j-u-b-engineers-announces-leadership-changes/" title="Permalink to J-U-B Engineers announces leadership changes&nbsp;" rel="bookmark"><img width="70" height="70" src="https://idahobusinessreview.com/files/2022/08/headshots2-1-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" srcset="https://idahobusinessreview.com/files/2022/08/headshots2-1-70x70.jpg 70w, https://idahobusinessreview.com/files/2022/08/headshots2-1-200x200.jpg 200w, https://idahobusinessreview.com/files/2022/08/headshots2-1-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2022/08/23/j-u-b-engineers-announces-leadership-changes/">J-U-B Engineers announces leadership changes&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">August 23, 2022</span></span>
		</li>
		
				</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /--><div id="categort-posts-widget-9" class="widget categort-posts"><div class="widget-top"><h4><a href="https://idahobusinessreview.com/category/top-stories/">Top Stories</a>		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2022/08/24/st-lukes-clinic-is-moving-into-south-nampa/" title="Permalink to Biz &#8216;Bite:&#8217; St. Luke&#8217;s is moving into South Nampa" rel="bookmark"><img width="70" height="70" src="https://idahobusinessreview.com/files/2022/08/st-lukes-groundbreaking-aug-22-20022_cropped-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" srcset="https://idahobusinessreview.com/files/2022/08/st-lukes-groundbreaking-aug-22-20022_cropped-70x70.jpg 70w, https://idahobusinessreview.com/files/2022/08/st-lukes-groundbreaking-aug-22-20022_cropped-200x200.jpg 200w, https://idahobusinessreview.com/files/2022/08/st-lukes-groundbreaking-aug-22-20022_cropped-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2022/08/24/st-lukes-clinic-is-moving-into-south-nampa/">Biz &#8216;Bite:&#8217; St. Luke&#8217;s is moving into South Nampa</a></h3>
			 <span class="date"><span class="tie-date">August 24, 2022</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2022/08/23/biz-bite68-million-financing-for-apartments-in-meridian/" title="Permalink to Biz &#8216;Bite:&#8217; $68M financing for apartments in Meridian" rel="bookmark"><img width="70" height="70" src="https://idahobusinessreview.com/files/2022/08/Village-Apartments-70x70.png" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" srcset="https://idahobusinessreview.com/files/2022/08/Village-Apartments-70x70.png 70w, https://idahobusinessreview.com/files/2022/08/Village-Apartments-200x200.png 200w, https://idahobusinessreview.com/files/2022/08/Village-Apartments-100x100.png 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2022/08/23/biz-bite68-million-financing-for-apartments-in-meridian/">Biz &#8216;Bite:&#8217; $68M financing for apartments in Meridian</a></h3>
			 <span class="date"><span class="tie-date">August 23, 2022</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2022/08/22/us-vs-idaho-involuntary-terminations/" title="Permalink to US vs. Idaho involuntary terminations" rel="bookmark"><img width="70" height="70" src="https://idahobusinessreview.com/files/2022/08/Idaho-involuntary-terminations-june-2022-70x70.png" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" srcset="https://idahobusinessreview.com/files/2022/08/Idaho-involuntary-terminations-june-2022-70x70.png 70w, https://idahobusinessreview.com/files/2022/08/Idaho-involuntary-terminations-june-2022-200x200.png 200w, https://idahobusinessreview.com/files/2022/08/Idaho-involuntary-terminations-june-2022-100x100.png 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2022/08/22/us-vs-idaho-involuntary-terminations/">US vs. Idaho involuntary terminations</a></h3>
			 <span class="date"><span class="tie-date">August 22, 2022</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2021/07/20/nampas-new-60-acre-business-park/" title="Permalink to Nampa&#8217;s new 60-acre business park&nbsp;" rel="bookmark"><img width="70" height="70" src="https://idahobusinessreview.com/files/2021/07/Fuller84_business_park_groundbreaking-70x70.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Groundbreaking at the Fuller84 Business Park site in Nampa on July 15." loading="lazy" srcset="https://idahobusinessreview.com/files/2021/07/Fuller84_business_park_groundbreaking-70x70.jpg 70w, https://idahobusinessreview.com/files/2021/07/Fuller84_business_park_groundbreaking-200x200.jpg 200w, https://idahobusinessreview.com/files/2021/07/Fuller84_business_park_groundbreaking-100x100.jpg 100w" sizes="(max-width: 70px) 100vw, 70px" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2021/07/20/nampas-new-60-acre-business-park/">Nampa&#8217;s new 60-acre business park&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">July 20, 2021</span></span>
		</li>
			<li >
							<div class="post-thumbnail">
					<a href="https://idahobusinessreview.com/2021/07/16/who-has-covid-19-vaccination-requirements/" title="Permalink to Who has COVID-19 vaccination requirements?&nbsp;" rel="bookmark"><img width="70" height="53" src="https://idahobusinessreview.com/files/2010/08/saint-als-health.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Saint Alphonsus Regional Medical Center in Boise." loading="lazy" /></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://idahobusinessreview.com/2021/07/16/who-has-covid-19-vaccination-requirements/">Who has COVID-19 vaccination requirements?&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a></h3>
			 <span class="date"><span class="tie-date">July 16, 2021</span></span>
		</li>
		
				</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /--></aside>
</div> <!-- .content-wrap -->
<aside class="sidebar">
<div id="dfp-ad-widget-79" class="widget dfp-ad-widget-class"><div><!-- idahobusiness -->		<div id="div-gpt-ad-rightrail_300x100"
		     class="div-gpt-ad-rightrail_300x100 idahobusiness dfp_ad_pos">
			<script type='text/javascript'>
				googletag.cmd.push(function () {
					googletag.display('div-gpt-ad-rightrail_300x100');
					googletag.pubads().collapseEmptyDivs(true);
				});
			</script>
		</div>
		</div></div><!-- .widget /--><div id="text-html-widget-27" class="widget text-html"><div class="widget-top"><h4>Free Daily Email Alerts</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div ><a href="https://idahobusinessreview.com/email-updates/"><img src="https://idahobusinessreview.com/files/2019/04/e-Alert_Sign-ups_IBR.png" /></a>
				</div><div class="clear"></div></div></div><!-- .widget /--><div id="social-9" class="widget social-icons-widget"><div class="widget-top"><h4>Follow IBR</h4><div class="stripe-line"></div></div>
						<div class="widget-container">	<div class="social-icons icon_32">
		<a class="ttip" title="Rss" href="https://idahobusinessreview.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="ttip" title="Facebook" href="https://www.facebook.com/IdahoBusinessReview/" target="_blank"><i class="tieicon-facebook"></i></a><a class="ttip" title="Twitter" href="https://twitter.com/IBRnews" target="_blank"><i class="tieicon-twitter"></i></a><a class="ttip" title="LinkedIn" href="https://www.linkedin.com/company/idaho-business-review" target="_blank"><i class="tieicon-linkedin"></i></a><a class="ttip" title="Youtube" href="https://www.youtube.com/channel/UC59PCuG4AfDCN_TkgX26x2A" target="_blank"><i class="tieicon-youtube"></i></a><a class="ttip" title="instagram" href="https://www.instagram.com/ibrnews/" target="_blank"><i class="tieicon-instagram"></i></a><a class="ttip" title="photo" href="http://www.idahobusinessreview.smugmug.com/" target="_blank"><i class="tieicon-photo"></i></a>	</div>

	</div></div><!-- .widget /--><div id="dfp-ad-widget-2" class="widget dfp-ad-widget-class"><div><!-- idahobusiness -->		<div id="div-gpt-ad-rightrail_atf"
		     class="div-gpt-ad-rightrail_atf idahobusiness dfp_ad_pos">
			<script type='text/javascript'>
				googletag.cmd.push(function () {
					googletag.display('div-gpt-ad-rightrail_atf');
					googletag.pubads().collapseEmptyDivs(true);
				});
			</script>
		</div>
		</div></div><!-- .widget /--><div id="dmc-widget-text-1071291029" class="widget dmc_widgetize_html_dmc_wp_widget_text">
<div></div></div><!-- .widget /--><div id="dfp-ad-widget-4" class="widget dfp-ad-widget-class"><div><!-- idahobusiness -->		<div id="div-gpt-ad-rightrail_stf"
		     class="div-gpt-ad-rightrail_stf idahobusiness dfp_ad_pos">
			<script type='text/javascript'>
				googletag.cmd.push(function () {
					googletag.display('div-gpt-ad-rightrail_stf');
					googletag.pubads().collapseEmptyDivs(true);
				});
			</script>
		</div>
		</div></div><!-- .widget /--><div id="text-html-widget-18" class="widget text-html"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div ><!-- /21669907858/BTM_BetterSMB_Network_300x200 -->
<div id='div-gpt-ad-1576771721921-0' style='width: 300px; height: 200px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1576771721921-0'); });
  </script>
</div>
				</div><div class="clear"></div></div></div><!-- .widget /--><div id="dmc-post-feed-3" class="widget widget_dmc-post-feed"><div class="widget-container"><div class="digital-edition">
<div class="widget-top ">
<h4><a href="/digital-edition/"><a href="https://idahobusinessreview.com/category/digital-edition/">Digital Edition</a></a></h4>
</div><a href="/digital-edition/"><img width="195" height="300" src="https://idahobusinessreview.com/files/2022/08/ibr-e-edition-195x300.jpg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://idahobusinessreview.com/files/2022/08/ibr-e-edition-195x300.jpg 195w, https://idahobusinessreview.com/files/2022/08/ibr-e-edition-391x600.jpg 391w, https://idahobusinessreview.com/files/2022/08/ibr-e-edition-114x175.jpg 114w, https://idahobusinessreview.com/files/2022/08/ibr-e-edition.jpg 400w" sizes="(max-width: 195px) 100vw, 195px" /></a>
<p>The Digital Edition of Idaho Business News is available to both print and online subscribers.</p>
<p><a href="/digital-edition/"><strong>Current edition</strong></a></p></div></div></div><!-- .widget /--><div id="dfp-ad-widget-3" class="widget dfp-ad-widget-class"><div><!-- idahobusiness -->		<div id="div-gpt-ad-rightrail_btf"
		     class="div-gpt-ad-rightrail_btf idahobusiness dfp_ad_pos">
			<script type='text/javascript'>
				googletag.cmd.push(function () {
					googletag.display('div-gpt-ad-rightrail_btf');
					googletag.pubads().collapseEmptyDivs(true);
				});
			</script>
		</div>
		</div></div><!-- .widget /--><div id="facebook-widget-2" class="widget facebook-widget"><div class="widget-top"><h4>Find us on Facebook		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="facebook-box">
				<iframe src="https://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/IdahoBusinessReview&amp;width=300&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->		<style>

.sidebar-narrow .ao_tbl_cell{
padding-left:0px !Important;
padding-bottom:2px;
}
.sidebar-narrow #form_0028_ao_submit_button{float:left;}

</style>		</aside>
<div class="clear"></div>		<div class="clear"></div>
	</div><!-- .container /-->

	<div class="e3lan-bottom">					<div class="top-ad-desktop">

</div>

<div class="top-ad-mobile">

</div>				</div>	</div><!-- .container -->

	<footer class="fade-in animated4">
	<div id="footer-widget-area" class="footer-3c container">

			<div id="footer-first" class="footer-widgets-box">
			<div id="text-html-widget-2" class="footer-widget text-html"><div class="footer-widget-top"><h4>My Account</h4></div>
						<div class="footer-widget-container"><div ><ul id="footer-top-menu-liney">

<li>
<a href="/2022/08/26/biz-bite-boise-buys-mobile-home-park/?dmcss=login">LOG IN</a>
</li>
<li>
<a href="http://idahobusinessreview.com/subscribe">SUBSCRIBE</a>
</li>
<li>
<a href="https://idahobusinessreview.com/email-updates/">FREE EMAIL NEWSLETTERS</a>
</li>
<li>
<a href="https://idahobusinessreview.com/manage-account-fc/">MANAGE ACCOUNT</a>
</li>
<li>
<a href="http://bridgetowermedia.com/privacy-policy/" target="_blank">PRIVACY POLICY</a>
</li>

<li>
<a href="https://bridgetowermedia.com/ccpa/" target="_blank">YOUR CALIFORNIA PRIVACY RIGHTS/PRIVACY POLICY</a>
</li>

<li>
<a href="https://bridgetowermedia.com/cookie-policy/" target="_blank">DO NOT SELL MY INFO/COOKIE POLICY</a>
</li>

<li>
<a href="http://bridgetowermedia.com/subscriber-agreement/">SUBSCRIBER AGREEMENT</a>
</li>
</ul>
				</div><div class="clear"></div></div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
					<div id="recent-posts-nocache-2" class="footer-widget widget_recent_entries_nocache">		<div class="footer-widget-top"><h4>Recent Posts</h4></div>
						<div class="footer-widget-container">		<ul>
					<li>
				<a href="https://idahobusinessreview.com/2022/08/26/biz-bite-aha-started-flights-to-idaho-falls-then-went-under/" title="Biz &#8216;Bite:&#8217; aha! started flights to Idaho Falls, then went under&nbsp;&lt;span class=&quot;dmcss_key_icon&quot;&gt;&lt;img alt=&quot;(access required)&quot; src=&quot;/files/2014/03/lock1.png&quot; border=0/&gt;&lt;/span&gt;">Biz &#8216;Bite:&#8217; aha! started flights to Idaho Falls, then went under&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a>
						</li>
					<li>
				<a href="https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/" title="Biz &#8216;Bite:&#8217; Boise buys mobile home park&nbsp;&lt;span class=&quot;dmcss_key_icon&quot;&gt;&lt;img alt=&quot;(access required)&quot; src=&quot;/files/2014/03/lock1.png&quot; border=0/&gt;&lt;/span&gt;">Biz &#8216;Bite:&#8217; Boise buys mobile home park&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a>
						</li>
					<li>
				<a href="https://idahobusinessreview.com/2022/08/26/military-families-housing-benefits-lag-as-rents-explode/" title="Military families&#8217; housing benefits lag as rents explode&nbsp;&lt;span class=&quot;dmcss_key_icon&quot;&gt;&lt;img alt=&quot;(access required)&quot; src=&quot;/files/2014/03/lock1.png&quot; border=0/&gt;&lt;/span&gt;">Military families&#8217; housing benefits lag as rents explode&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a>
						</li>
					<li>
				<a href="https://idahobusinessreview.com/2022/08/26/29-of-idaho-grads-eligible-of-20000-student-loan-relief/" title="29% of Idaho grads eligible of $20,000 student loan relief&nbsp;&lt;span class=&quot;dmcss_key_icon&quot;&gt;&lt;img alt=&quot;(access required)&quot; src=&quot;/files/2014/03/lock1.png&quot; border=0/&gt;&lt;/span&gt;">29% of Idaho grads eligible of $20,000 student loan relief&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a>
						</li>
					<li>
				<a href="https://idahobusinessreview.com/2022/08/26/marzocco-joins-the-mike-brown-group/" title="Marzocco joins The Mike Brown Group&nbsp;&lt;span class=&quot;dmcss_key_icon&quot;&gt;&lt;img alt=&quot;(access required)&quot; src=&quot;/files/2014/03/lock1.png&quot; border=0/&gt;&lt;/span&gt;">Marzocco joins The Mike Brown Group&nbsp;<span class="dmcss_key_icon"><img alt="(access required)" src="/files/2014/03/lock1.png" border=0/></span></a>
						</li>
				</ul>
		</div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

			<div id="footer-third" class="footer-widgets-box">
			<div id="text-html-widget-6" class="footer-widget text-html"><div class="footer-widget-top"><h4>Idaho Business Review</h4></div>
						<div class="footer-widget-container"><div ><ul>
<li>
<a href="/about/">ABOUT US</a>
</li>
<li>
<a href="/advertising/">ADVERTISING</a>
</li>
<li>
<a href="/contact-us/">CONTACT US</a>
</li>
<li>
<a href="/frequently-asked-questions/">FREQUENTLY ASKED QUESTIONS</a>
</li>
<li>
<a href="/accessibility-statement/">ACCESSIBILITY STATEMENT</a>
</li>
<li>
<a href="/events/">OUR PUBLICATIONS</a>
</li>
<li>
<a href="/business-announcements/">SUBMIT BUSINESS ANNOUNCEMENTS</a>
</li>

</ul>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8940855753907675",
    enable_page_level_ads: true
  });
</script>
<p></p>
				</div><div class="clear"></div></div></div><!-- .widget /-->		</div><!-- #third .widget-area -->
	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
	<div class="clear"></div>
	<div class="footer-bottom fade-in animated4">
		<div class="container">
				<div class="social-icons icon_flat">
		<a class="ttip" title="Rss" href="https://idahobusinessreview.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="ttip" title="Facebook" href="https://www.facebook.com/IdahoBusinessReview/" target="_blank"><i class="tieicon-facebook"></i></a><a class="ttip" title="Twitter" href="https://twitter.com/IBRnews" target="_blank"><i class="tieicon-twitter"></i></a><a class="ttip" title="LinkedIn" href="https://www.linkedin.com/company/idaho-business-review" target="_blank"><i class="tieicon-linkedin"></i></a><a class="ttip" title="Youtube" href="https://www.youtube.com/channel/UC59PCuG4AfDCN_TkgX26x2A" target="_blank"><i class="tieicon-youtube"></i></a><a class="ttip" title="instagram" href="https://www.instagram.com/ibrnews/" target="_blank"><i class="tieicon-instagram"></i></a><a class="ttip" title="photo" href="http://www.idahobusinessreview.smugmug.com/" target="_blank"><i class="tieicon-photo"></i></a>	</div>

				<div class="alignleft">
			<span class="four_fifth" style="display: inline-block;text-align: center;line-height: 22px;"><span style="white-space:nowrap;">Copyright © 2022</span> <span class="vcard"><span class="fn n org" style="white-space:nowrap;">Idaho Business Review</span></span> | <span class="adr"><span class="street-address" style="white-space:nowrap;">4696 W. Overland Road, Suite 180</span>, <span  style="white-space:nowrap;"><span class="locality">Boise</span>, <span class="region">ID</span> <span class="postal-code">83705</span></span></span> | <a href="tel:(208) 336-3768" style="white-space:nowrap;">Phone: (208) 336-3768</a> <a href="fax:(208) 336-5534" style="white-space:nowrap;">Fax: (208) 336-5534</a></span></span>
<span class="one_fifth_last"><a href="http://bridgetowermedia.com" style="max-width:140px;"><img alt="bridge tower media logo" src="https://idahobusinessreview.com/files/2020/03/btm-white1.png" style="max-width:140px;width:100%;"></a></span>			</div>
		</div><!-- .Container -->
	</div><!-- .Footer bottom -->

</div><!-- .Wrapper -->
	<div id="topcontrol" class="tieicon-up-open" title="Scroll To Top"></div>
<div id="fb-root"></div>
<div class='info_link_footer_div'><script type="text/javascript"> var infolinks_pid = 3268076; var infolinks_wsid = 0; </script> 
<script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script></div><script type="application/ld+json">{
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "headline": "Biz 'Bite:' Boise buys mobile home park",
    "author": {
        "@type": "Person",
        "name": "IBR Staff"
    },
    "authorByline": {
        "@type": "Person",
        "name": "IBR Staff"
    },
    "datePublished": "2022-08-26T12:04:11-06:00",
    "articleSection": "IBR Headlines",
    "url": "https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/",
    "image": "https://idahobusinessreview.com/files/2022/08/Depositphotos_244509542_XL-scaled.jpg",
    "publisher": {
        "@type": "Organization",
        "name": "Idaho Business Review"
    },
    "thumbnailUrl": "https://idahobusinessreview.com/files/2022/08/Depositphotos_244509542_XL-scaled.jpg",
    "dateCreated": "2022-08-26T12:04:11-06:00",
    "dateModified": "2022-08-26T12:04:11-06:00",
    "creator": {
        "@type": "Person",
        "name": "IBR Staff"
    },
    "keywords": "IBR Headlines, News, Real Estate",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://idahobusinessreview.com/2022/08/26/biz-bite-boise-buys-mobile-home-park/"
    }
}</script><!--googleoff: all--><div id="cookie-law-info-bar" data-nosnippet="true"><span><div class="cli-bar-container cli-style-v2"><div class="cli-bar-message">We use cookies on our website to give you the most relevant experience by remembering your preferences and repeat visits. By clicking “Accept”, you consent to the use of ALL the cookies.</div><div class="cli-bar-btn_container"><a role='button' tabindex='0' class="cli_settings_button" style="margin:0px 10px 0px 5px;" >Cookie settings</a><a role='button' tabindex='0' data-cli_action="accept" id="cookie_action_close_header"  class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block; ">ACCEPT</a></div></div></span></div><div id="cookie-law-info-again" style="display:none;" data-nosnippet="true"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" data-nosnippet="true" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
	<div class="cli-modal-content cli-bar-popup">
	  	<button type="button" class="cli-modal-close" id="cliModalClose">
			<svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
			<span class="wt-cli-sr-only">Close</span>
	  	</button>
	  	<div class="cli-modal-body">
			<div class="cli-container-fluid cli-tab-container">
	<div class="cli-row">
		<div class="cli-col-12 cli-align-items-stretch cli-px-0">
			<div class="cli-privacy-overview">
				<h4>Privacy Overview</h4>				<div class="cli-privacy-content">
					<div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</div>
				</div>
				<a class="cli-privacy-readmore"  aria-label="Show more" tabindex="0" role="button" data-readmore-text="Show more" data-readless-text="Show less"></a>			</div>
		</div>
		<div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
												<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab">
								Necessary							</a>
							<div class="wt-cli-necessary-checkbox">
                        <input type="checkbox" class="cli-user-preference-checkbox"  id="wt-cli-checkbox-necessary" data-id="checkbox-necessary" checked="checked"  />
                        <label class="form-check-label" for="wt-cli-checkbox-necessary">Necessary</label>
                    </div>
                    <span class="cli-necessary-caption">Always Enabled</span> 						</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="necessary">
								<div class="wt-cli-cookie-description">
									Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="non-necessary" data-toggle="cli-toggle-tab">
								Non-necessary							</a>
							<div class="cli-switch">
                        <input type="checkbox" id="wt-cli-checkbox-non-necessary" class="cli-user-preference-checkbox"  data-id="checkbox-non-necessary"  checked='checked' />
                        <label for="wt-cli-checkbox-non-necessary" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Non-necessary</span></label>
                    </div>						</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="non-necessary">
								<div class="wt-cli-cookie-description">
									Any cookies that may not be particularly necessary for the website to function and is used specifically to collect user personal data via analytics, ads, other embedded contents are termed as non-necessary cookies. It is mandatory to procure user consent prior to running these cookies on your website.								</div>
							</div>
						</div>
					</div>
										</div>
	</div>
</div>
	  	</div>
	  	<div class="cli-modal-footer">
			<div class="wt-cli-element cli-container-fluid cli-tab-container">
				<div class="cli-row">
					<div class="cli-col-12 cli-align-items-stretch cli-px-0">
						<div class="cli-tab-footer wt-cli-privacy-overview-actions">
						
															<a id="wt-cli-privacy-save-btn" role="button" tabindex="0" data-cli-action="accept" class="wt-cli-privacy-btn cli_setting_save_button wt-cli-privacy-accept-btn cli-btn">SAVE & ACCEPT</a>
													</div>
						
					</div>
				</div>
			</div>
		</div>
	</div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<!--googleon: all--><!-- START Quantcast By WP-Plugin: Quantcast-Quantifier http://wordpress.org/extend/plugins/quantcast-quantifier/ -->
<!-- Start Quantcast tag -->
<script type="text/javascript">
_qoptions={
qacct:"p-29W-admf9poxY", 
labels:"Business"
};
</script>
<script type="text/javascript" src="//edge.quantserve.com/quant.js"></script>
<noscript>
<img src="//pixel.quantserve.com/pixel/p-29W-admf9poxY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>
<!-- End Quantcast tag -->

<script type="text/javascript">
    __compete_code = '0406a660fcef05313cf19e49a64a9f9b';
    (function () {
        var s = document.createElement('script'),
            e = document.getElementsByTagName('script')[0],
            t = document.location.protocol.toLowerCase() === 'https:' ?
                '//c.compete.com/bootstrap/' :
                '//c.compete.com/bootstrap/';
            s.src = t + __compete_code + '/bootstrap.js';
            s.type = 'text/javascript';
            s.async = true;
            if (e) { e.parentNode.insertBefore(s, e); }
        }());
</script>

<!-- END Quantcast-Quantifier -->
        <!-- wpsolr - ajax auto completion nonce -->
        <input type="hidden" id="wpsolr_autocomplete_nonce"
               value="fea4ef3937">

		<script type="text/javascript">
jQuery(".close-ad-image").click(function() {
    jQuery(this).parent().hide();
});
jQuery(document).ready(function($){

	$(".top-menu-footer-liney").click(function(event){
    
		event.preventDefault();
    
		var offset = $($(this).attr('href')).offset().top;
	
		offset = offset - 200;
    
		$('html, body').animate({scrollTop:offset}, 3000);
});
  
	});

</script>

<script>
jQuery(window).bind("load", function() {
var templateUrl = window.location.href;
  jQuery('#the-post .share-post li:nth-child(2)').append('<span class="fb-share"><iframe src="https://www.facebook.com/plugins/share_button.php?href='+templateUrl+' &layout=button_count&size=small&mobile_iframe=true&width=86&height=20&appId" width="86" height="20" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allow="encrypted-media"></iframe></span>');
});

jQuery(document).ready(function($){
  if(window.location.href.indexOf("manage-account-em") > -1) {
        jQuery("#login_link").trigger( "click" );
        jQuery("#subscribe_tab").remove( );
    }
});

</script>

<!-- Jarida include the function for subscribe iframe -->
<script>
jQuery(document).ready(function () {   
       jQuery("#form_opening iframe").attr("scrolling", "yes");
       jQuery("#form_opening iframe").attr("OVERFLOW", "auto");       	   
});
</script>

<!-- Code for intent ads -->
<script>
jQuery(document).ready(function(){
setTimeout(function(){
if (jQuery('.article_dfp_ads iframe').length > 0) {
    jQuery(".article_dfp_ads").css("display", "block");

}
else
{
jQuery(".article_dfp_ads").css("display", "none");

}
},9000);
});
</script>
<!--End code for intent ads -->

<!-- code tag for sifitag -->
<script async src='https://tag.simpli.fi/sifitag/4e7bafe0-31ad-0139-8425-06b4c2516bae'></script>

<script id="parsely-cfg" src="//cdn.parsely.com/keys/idahobusinessreview.com/p.js"></script>
    <!-- Facebook Pixel Event Code -->
    <script type='text/javascript'>
        document.addEventListener( 'wpcf7mailsent', function( event ) {
        if( "fb_pxl_code" in event.detail.apiResponse){
          eval(event.detail.apiResponse.fb_pxl_code);
        }
      }, false );
    </script>
    <!-- End Facebook Pixel Event Code -->
    <div id='fb-pxl-ajax-code'></div><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: 7KD Exit Intent ID Business Review -->
<script>(function(d,u,ac){var s=d.createElement('script');s.type='text/javascript';s.src='https://a.omappapi.com/app/js/api.min.js';s.async=true;s.dataset.user=u;s.dataset.campaign=ac;d.getElementsByTagName('head')[0].appendChild(s);})(document,27526,'ciiogecsm1patmponzjz');</script>
<!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Tessa - Subscribe page abandon --><div id="om-gc9i97ojgwf3fpv9fwnu-holder"></div><script>var gc9i97ojgwf3fpv9fwnu,gc9i97ojgwf3fpv9fwnu_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){gc9i97ojgwf3fpv9fwnu_poll(function(){if(window['om_loaded']){if(!gc9i97ojgwf3fpv9fwnu){gc9i97ojgwf3fpv9fwnu=new OptinMonsterApp();return gc9i97ojgwf3fpv9fwnu.init({"u":"27526.828727","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;gc9i97ojgwf3fpv9fwnu=new OptinMonsterApp();gc9i97ojgwf3fpv9fwnu.init({"u":"27526.828727","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Custom Lightbox / Trial Idaho Business Review --><div id="om-kjr1gqbbfqv4hyew-holder"></div><script>var kjr1gqbbfqv4hyew,kjr1gqbbfqv4hyew_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){kjr1gqbbfqv4hyew_poll(function(){if(window['om_loaded']){if(!kjr1gqbbfqv4hyew){kjr1gqbbfqv4hyew=new OptinMonsterApp();return kjr1gqbbfqv4hyew.init({"u":"27526.497842","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;kjr1gqbbfqv4hyew=new OptinMonsterApp();kjr1gqbbfqv4hyew.init({"u":"27526.497842","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Custom Lightbox / Estate Idaho Business Review --><div id="om-cd4ds9hgjw2urgzy-holder"></div><script>var cd4ds9hgjw2urgzy,cd4ds9hgjw2urgzy_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){cd4ds9hgjw2urgzy_poll(function(){if(window['om_loaded']){if(!cd4ds9hgjw2urgzy){cd4ds9hgjw2urgzy=new OptinMonsterApp();return cd4ds9hgjw2urgzy.init({"u":"27526.496838","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;cd4ds9hgjw2urgzy=new OptinMonsterApp();cd4ds9hgjw2urgzy.init({"u":"27526.496838","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Custom Lightbox / Case Study Idaho Business Review --><div id="om-yzlb6lbkz6pc9mzv-holder"></div><script>var yzlb6lbkz6pc9mzv,yzlb6lbkz6pc9mzv_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){yzlb6lbkz6pc9mzv_poll(function(){if(window['om_loaded']){if(!yzlb6lbkz6pc9mzv){yzlb6lbkz6pc9mzv=new OptinMonsterApp();return yzlb6lbkz6pc9mzv.init({"u":"27526.497841","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;yzlb6lbkz6pc9mzv=new OptinMonsterApp();yzlb6lbkz6pc9mzv.init({"u":"27526.497841","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Custom Floating Bar / Firm Idaho Business Review --><div id="om-mjtcha0iu9zchktd-holder"></div><script>var mjtcha0iu9zchktd,mjtcha0iu9zchktd_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){mjtcha0iu9zchktd_poll(function(){if(window['om_loaded']){if(!mjtcha0iu9zchktd){mjtcha0iu9zchktd=new OptinMonsterApp();return mjtcha0iu9zchktd.init({"u":"27526.497847","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;mjtcha0iu9zchktd=new OptinMonsterApp();mjtcha0iu9zchktd.init({"u":"27526.497847","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Custom Floating Bar / Estate Idaho Business Review --><div id="om-yrtk5wj1smnya0xl-holder"></div><script>var yrtk5wj1smnya0xl,yrtk5wj1smnya0xl_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){yrtk5wj1smnya0xl_poll(function(){if(window['om_loaded']){if(!yrtk5wj1smnya0xl){yrtk5wj1smnya0xl=new OptinMonsterApp();return yrtk5wj1smnya0xl.init({"u":"27526.497844","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;yrtk5wj1smnya0xl=new OptinMonsterApp();yrtk5wj1smnya0xl.init({"u":"27526.497844","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster -->		<script type="text/javascript">
		var ciiogecsm1patmponzjz_shortcode = true;var gc9i97ojgwf3fpv9fwnu_shortcode = true;var kjr1gqbbfqv4hyew_shortcode = true;var cd4ds9hgjw2urgzy_shortcode = true;var yzlb6lbkz6pc9mzv_shortcode = true;var mjtcha0iu9zchktd_shortcode = true;var yrtk5wj1smnya0xl_shortcode = true;		</script>
		<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/idahobusinessreview.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-includes/js/thickbox/thickbox.js' id='thickbox-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/mu-plugins/mkt/mkt_footer.js' id='mkingtbs_foot-js'></script>
<script type='text/javascript' id='loadadjs-js-extra'>
/* <![CDATA[ */
var adajax_object = {"ajax_url":"https:\/\/idahobusinessreview.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/BTMActOn/js/interads.js' id='loadadjs-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/wpsolr-pro/wpsolr/core/js/devbridge/jquery.autocomplete.js' id='solr_auto_js1-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/wpsolr-pro/wpsolr/core/bower_components/jsurl/url.min.js' id='urljs-js'></script>
<script type='text/javascript' id='autocomplete-js-extra'>
/* <![CDATA[ */
var wp_localize_script_autocomplete = {"data":{"ajax_url":"https:\/\/idahobusinessreview.com\/wp-admin\/admin-ajax.php","lang":"","is_show_url_parameters":true,"is_ajax":false,"SEARCH_PARAMETER_S":"s","SEARCH_PARAMETER_SEARCH":"search","SEARCH_PARAMETER_Q":"wpsolr_q","SEARCH_PARAMETER_FQ":"wpsolr_fq","SEARCH_PARAMETER_SORT":"wpsolr_sort","SEARCH_PARAMETER_PAGE":"wpsolr_page","SORT_CODE_BY_RELEVANCY_DESC":"sort_by_relevancy_desc","css_ajax_container_page_title":".page-title","css_ajax_container_page_sort":".woocommerce-ordering select,.select_field","css_ajax_container_results":".products,.results-by-facets","css_ajax_container_overlay":".products,.results-by-facets","css_ajax_container_pagination":"nav.woocommerce-pagination,.paginate_div","css_ajax_container_pagination_page":"a.page-numbers,a.paginate","css_ajax_container_results_count":".woocommerce-result-count,.res_info","ajax_delay_ms":"","redirect_search_home":"","suggestions_icon":"https:\/\/idahobusinessreview.com\/wp-content\/plugins\/wpsolr-pro\/wpsolr\/core\/images\/wpsolr-ajax-loader.gif","wpsolr_autocomplete_is_active":true,"wpsolr_autocomplete_selector":[],"wpsolr_autocomplete_action":"wdm_return_solr_rows","wpsolr_autocomplete_nonce_selector":"#wpsolr_autocomplete_nonce","wpsolr_is_search_admin":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/wpsolr-pro/wpsolr/core/js/autocomplete_solr.js' id='autocomplete-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/wpsolr-pro/wpsolr/core/js/loadingoverlay/loadingoverlay.min.js' id='loadingoverlay-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/wpsolr-pro/wpsolr/pro/extensions/theme/template/facet-range/wpsolr-facet-range.js' id='wpsolr-facet-range-js-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/wpsolr-pro/wpsolr/pro/extensions/theme/template/facet-color-picker/wpsolr-facet-color-picker.js' id='wpsolr-facet-color-picker-js-js'></script>
<script type='text/javascript' id='tie-scripts-js-extra'>
/* <![CDATA[ */
var tie = {"go_to":"Go to...","ajaxurl":"https:\/\/idahobusinessreview.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","is_singular":"1","reading_indicator":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/themes/jarida/js/tie-scripts.js' id='tie-scripts-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/slidedeck3-personal/js/jail.js' id='jail-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/slidedeck3-personal/js/jquery-mousewheel/jquery.mousewheel.min.js' id='scrolling-js-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/slidedeck3-personal/js/jquery.easing.1.3.js' id='jquery-easing-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/slidedeck3-personal/js/slidedeck.jquery.js' id='slidedeck-library-js-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/slidedeck3-personal/js/slidedeck-public.js' id='slidedeck-public-js'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js' id='twitter-intent-api-js'></script>
<script type='text/javascript' src='https://idahobusinessreview.com/wp-content/plugins/optinmonster/assets/js/helper.js' id='optinmonster-wp-helper-js'></script>
<script type="text/javascript">
var slideDeck2URLPath = "https://idahobusinessreview.com/wp-content/plugins/slidedeck3-personal";
var slideDeck2iframeByDefault = false;
</script>
		<script type="text/javascript">var omapi_localized = {
			ajax: 'https://idahobusinessreview.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1',
			nonce: '077d991244',
			slugs: 
			{"ciiogecsm1patmponzjz":{"slug":"ciiogecsm1patmponzjz","mailpoet":false},"gc9i97ojgwf3fpv9fwnu":{"slug":"gc9i97ojgwf3fpv9fwnu","mailpoet":false},"kjr1gqbbfqv4hyew":{"slug":"kjr1gqbbfqv4hyew","mailpoet":false},"cd4ds9hgjw2urgzy":{"slug":"cd4ds9hgjw2urgzy","mailpoet":false},"yzlb6lbkz6pc9mzv":{"slug":"yzlb6lbkz6pc9mzv","mailpoet":false},"mjtcha0iu9zchktd":{"slug":"mjtcha0iu9zchktd","mailpoet":false},"yrtk5wj1smnya0xl":{"slug":"yrtk5wj1smnya0xl","mailpoet":false}}		};</script>
				<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":284145,"object_key":"post","object_type":"post","term_ids":[57,3,5]};</script>
		</body>
</html>
